Backup not working

Hi,

I will create a backup on a separat harddrive from my EX4, but it’s not working.

The internal backup to other disk dosn’t work:

Problem with the Voloumn 2, see  http://community.wd.com/t5/WD-My-Cloud-EX4/Creation-of-second-drive-share-on-second-volume-fails/td-p/678851

WD support work on the issue.

But also the NAS to USB Backup dosn’t work.

I will backup 2 TB of data to a USB disk, I start the job, it’s very slow (1,5 GB per 6 hours).
After around 10 hours. thje USB backup job have tje status “cancel”.

Any idea, I haven’t cancel the job.

Thanks

Dirk

Hi Dirk, this issue is currently under investigation. In the meantime, maybe other users can share if they are experiencing the same problem. 

Hello Moderator -

Ah, well, this issue has been reported probably many times from day one when this NAS was delivered to market by many users I am sure.  It’s under investigation?  I expected to hear that the issue is a known issue and that it is fixed in the next firmware release and that WD is very sorry for releasing a product to market which was not tested and that the next firmware release has an ETA of tomorrow (since 2 months have already gone by since the last firmware update).  I’m losing confidence that this unit is going to get the appropriate support to address all the issues that have been encountered.

My original post can be found   here which deals with the failure of the backup funtionality of this NAS.

Hi Moderator,

Short comments to the backup problem:

  1. Backup via USB doesn’t running (very slow, cancel after few hours)

  2. Internal backup via 3th disk doesn’t running (see http://community.wd.com/t5/WD-My-Cloud-EX4/Creation-of-second-drive-share-on-second-volume-fails/td-p/678851-> Without share, no internal backup possible)

I runs a server with many data’s and not backup is possible.

Toady I started a copy from my notebook to a external hard disk via the network.

The statistic said: 33 hours

Is this the standard case for the EX4 to start backup remotly via network backup?

See the product description of the WD EX4, no way is possible.

“The WD My Cloud and the WD My Cloud EX4 Personal Cloud drives allow for scheduled and automatic backups to be saved onto them. There are multiple options that can be used in order to backup one or more computers while using one of the network drives. This article will provide information on how to use the recommended ways backup a computer using a WD My Cloud or WD My Cloud EX4 Personal Cloud as a backup drive“

 Thanks

Dirk

Hi Moderator,

In response to your request, I have a similar set of problems to Dirk’s. I bought my WD My Cloud EX4 in January 2014. I had a lot of problems initially with its slow data transfer speed, but I solved them by repositioning the EX4 drive closer to the router and using Ethernet cables rather than Powerline or WiFi. It’s not super fast now, but it’s fast enough. I’m using it as my main drive with two 3TB discs under RAID 1.The EX4 firmware is version 1.02.25, which is up to date.

I have tried three different ways of backing up my EX4, none of which is satisfactory:

(1) USB device - I tried a USB 3 backup from the EX4 to my 3TB My Book 1140 Essential, but I could not access it, and I received a warning that it was not compatible and faced imminent failure, which was a big disappointment given that it’s a WD backup product. Also my upgraded Smartware Pro (version 2.2.1 downloaded yesterday) did not allow backups from an EX4 to a disk on my PC, only from a disk on a PC to the EX4.

(2) 3rd disk - I also tried inserting a third disk into the EX4 running under RAID 1 but formatted as ‘Volume 2’ under JBOD, which I had hoped to use for backups. But I could not create a share on this volume so it did not appear as a destination option on the EX4’s backup pages, which meant that I could not use it as a backup disk.

(3) RAID 1 - Finally, I tried an internal backup from my personal share (185GB of data) to a backup share that I had created, both being on my EX4 under RAID 1. I thought this had failed after 6 hours as it showed 96% complete, while only a small % of the data had been backed up. It finally backed everything up after 14 hours. Surely this is far too slow, when the backup process all happens within the same disks on the EX4 and I am able to copy the same amount of data from the EX4 to a disk on my PC in less than 2 hours at 30 MBps (7x faster!).

I would welcome any help or suggestions, please.

Robin

Hi Moderator,

any updates for the backup issue with the EX4:

  • Backup USB not running - Canceled after via hours

3rd disk not running -> no share creation possible on 3rd disk

Also, a backup from the EX4 via Network to my PC with external harddrive isn’t possible.

After few hours of data copy, a read error comes up.

Not the same after restart the backup, every backup via network copy runs with different read errors of files to error.

After the escalation mail from you last Sunday I receive no updates.

A backup of my server is very important and a core feature of the WD EX4.

Why not running?

Please give support to this issue.

Thanks

Dirk

Hi WD Support

Thanks for the answer via Mail to my EX4 problem.

Answer:
My Requirement (Backup via USB or internal Disk) isn’t possible today.

Crazy

I will send back the EX4 to WD

Dirk

I purchased this drive to be able to backup to USB and mine isn’t working either.  Mine keeps showing “Cancel”.  I am sick of how buggy this thing is!  Please fix asap!

I can not back up to USB. It will allow me to create the back up but when I hit start the progress bar remains at zero and the device lights blink but eventually it will stop and say canceled but I did no such thing. I did this sever times and always the same results.

I have experienced these same problems.  It is very frustrating and also time consuming.  I purchased the EX4 so that I didn’t have to spend time managing my data.

When will WD get this beast working properly?

From what I have seen, there are times when the NAS is undertaking a backup when the status is incorrectly stated as “Cancel”. When I have looked at the share, the files are correctly backed up, but the status is not changed.

It is a bug, but backups appear to be working.

To check , mount the volume under Finder, and check it yourself.

Backup via USB EX4 to WD Mybook 4TB to  to  is not working since 2 EX4 bios updates ago.  This was verified by one of your techs via remote desktop access. 

He updated bios on Mybook Drive and this did not resolve issue.  

Just chiming in so that you know it is an actual ongoing issue.  WD EX4 cannot backup to WD Mybook 4 TB!

Recommend WD set up the same senario since they manufacture both devices and resolve issue.

Regards,

Steve

Hello All,

Just to follow up, I receive a replacement EX4 free of charge.  Unit was able to backup via NAS to USB perfectly.  WD remotely verified the unit was working correctly and then they updated the firmware to the current version.  After the update the unit was no longer able to backup.  WD rolled back the firmware and the unit functioned properly.  WD then duplicated the behavior in their facility.  I was told that this issue would be resolved in the next firmware update.

I have had a lot of issues with this device but I would like to say the level 2 techs have been courteous and helpful at all times.  I am hopeful that the top gurus are working to resolve this issue and also re-enable features that have been disabled.

Just purchased WD MyCloud EX2 2 Tb from amazon (2 weeks ago) not happy of this situation on a suposed high quality product to act as a robust home NAS.

Network performance is bellow any expectation… very bad.

I tried everything firmware is updated to the latest one 1.04.05 but problems still there.

Backups from USB to Appliance did not work at all … save the job config and nothing happens…

When I tried thru ftp or NFS to do a manual copy… takes a lifetime at the end start copying some files then suddenly connection becomes broken…

So I expect a serious valid response from WD tech support or my money back… I will continue to write serious complaints and reporting this situation across other forums so other professional users avoid to buy these products.

Today even worst … Now drives are not detected by unit. i rebooted it and the same : Say : not disks installed… :frowning: they are on it … Some info was a.ready loaded so i really want to return this product… Is clear for me that is a box with no reliable tech stable functionalities… Please I want my money back now!

No point asking for your money back here, we’re not WD, we’re not going to give any money to anyone…

This forum is for technical issues and learnings.

You seem to have a defective unit. Return it for a replacement to the retailer.

I bought my EX4 about a month ago and had been unable to do a NAS to USB backup sucessfully – always having the same problems reported here.  I looked through the posts for the EX2 on the other WD Community and found “Re: Problem with USB Backup - I had the same problem. After much trial-and-error I found out that SPACES in the jobname cause the problem.”  I tried backing up about 10 gigs of data without spaces in the job name and this was the first time I was able to backup successfully.  I removed the USB drive from the EX4 to verify that the files copied correctly on another machine.  They did.  I was beginning to worry that I should have purchased a Synology unit, but being able to do this backup has given me hope.  I will try a more substantial backup soon.

Wonderful - that fixed my backup problem.  By replacing the space with an underscore, the backup now shows “Backup Completed” as per my other backup jobs.

Also I have observed that if the Job Name is longer than (about) 16 to 18 characters then it will also complete the backup but show Cancelled as the completion status.

My problem backingup NAS EX4 to USB Mybook 4TB still persist after newest update that was to resolve this issue.  I have given WD 2 weeks to resolve and if not will return product for another brand.