Safe point not showing

I had V3 firmware all was working fine icluding a safepoint being done to the attached USB drive.

However when I went to change the safepoint times the finding safepoint kept serching .

I took the plunge and updated to the new firmware V4 and that went ok, hopeing that would cure finding my safepoints. However when i go to safepoints its still serching ?

I have rebooted both Mycloud and USB attachment

What can I do


Try a power cycle and/or a drive reset.

Can you explaine how to do these please

and will I loose any data and settings?

I found out and done them both. But still when I am on the dashboard and go to safepoints it just serches and says “looking for safempoints” with a spinning wheel.

Interestingly my usual safe point is still being done (to the attached USB drive) but I want to add and change my safepoints

Any ideas?

While the “finding safepoint” was going on I tried to set up a new one . I clicked local USB and that just spins looking as well.

I then unplugged the USB drive and tried again and it said “No USB device attached” So I then reconnected the USB drive and tried again and just a “searching for USB Devices” is shown.

It looks as though it cant show the attached USB Drive? The drive is a WD MyBook and I have rebooted that as well.

Any help please