My Cloud safepoint creation keep failed, help!

Hi, I have a 4T My Cloud in my home. Recently I was trying to create a safepoint for it. So far, I’ve been tried for at least 10 times and it failed every time.
Below is My Cloud status:

  • Firmware: v04.05.00-327
  • Diagnosis: OK
  • Used: 820G
  • A 5T NTFS external USB3 hard drive is connected to My Cloud. It can be discovered in My Cloud Safepoint Setting.
  • My OS is Mac OS
    Below is what I’ve tried:
  • Create a new safepoint in the My Cloud Setting, the safepoint creating can always start to copy files successfully. After one or one and half day, My Cloud will not be able to be discovered through either network or “WD Access” APP
  • After failed a few times, I thought it might be because of my home network’s issue. So I directly connect the My Cloud to my Macbook Pro directly and redo the safepoint creation. It is still the same as before.
  • Every time when I can’t access My Cloud, usually I will wait for one or two more days (just in case it is still backup even the network is failed) and then power it off. I’ve checked the safepoint external USB3 hard drive every time, some times it finished 450G, some time 700G, some times 800G. But every time, when the My Cloud is powered on again, it will tell me the safepoint is invalid and need to update. So I update every time but still failed.
    There seems is NO WAY to create a good safepoint for me, could someone help?

Couple of suggestions. Does the My Cloud Dashboard Notification/Alert mycloudnotificationicon indicate a reason for the Safepoint failure?

Check the USB drive to see if it has a selectable sleep mode. Could be the USB drive is going to sleep.

Safepoint is what it is. Some have trouble using it or want to have more control over what is back upped. Some of us no longer use Safepoint, instead we’ve setup our own method of backup. The following thread discusses an alternative to Safepoint. It does involve using SSH though to access the My Cloud at teh firmware level.

When the safepoint stopped response, I’ve checked the Notification and got an Event Code 1102. Based on the suggestion from WD support, I’ve turn off the indexing service last night. We will see if it could work.
I am pretty sure the USB is alive all the time.
The script alternative is a good idea. I will definitely try it if the safepoint failed again.
Thanks for the help!