Retrieved Files can't be deleted

I am new to the community.  I have a My Cloud Personal Storage device.  I recently reformated the HD of my desktop machine and installed Vista Business.  I retrieved my music files from the MyCloud and put them back on the desktop.  It kept the folder hierarchy that the files were in originally all the way from the root C; folder.  When I tried to move the files in to the My Music folder it says that the “Destination Folder Access is Denied - you need permission to perform this action.”

The folders are all shown as read only but it will not let me change them form that status.  

It appears that if I copy and paste the files from the MyCloud that i have full control over the files.  

As there is about 40gig of music I really want to either put it in the right place or delete it all and do a copy and paste.  

I feel like I am missing something obvious… Any help would be much appreciated.


Welcome to the WD Community.

Since the drive was formatted, the permissions are not the same as before.

Have you tried taking ownership of the files? If not, please try that and check the permissions on the folders.

See if the following link helps

Thanks for the info. I had tried part of this before with no luck but did not have all this info. I will give it a shot this weekend when I get back home. Thanks so much