Cannot copy files to public folder

I cannot copy files to my Shared Pictures folderr.  I can open the link.  I can open the folders.   I can open files in the folders.  And, I’m on the same wireless network as the MyCloud device.  But when I try to copy from my local pictures folder to the Shared Pictures folder under the Public directory, I get a box that pops up saying “Destination Folder Access Denied - You need permission to perform this action.”   My account has administrator privileges.  Why can’t I perform a very simply operation like copying to this directory?  

Are you doing a drag and drop or what steps do you take to try and transfer the pictures?

I am trying to back up my local Pictures folder with SyncToy.   It works on the other drives.  But not this one.  When I try to copy and paste, I get a message that access is denied and I need “permission” to do that.  Huh???  I have the folder designated as a drive on my computer and can access it by clicking it, like any other folder.   And, this seems to relate in particular to one of my folders.  I changed that folder to remove the “read only” attribute (which always seems to appear whether I tell it to or not), and am doing the same thing with the WD folder (although I suspect that’s going to take awhile).   Very frustrating.

… and, after waiting an hour to remove the “read only” status, it STILL doesn’t work.  WD?   Solutions please???


Have you tried contacting WD Support directly over the phone or through the email support?

Please note that the WD Community is a user to user forum, not a WD Support venue.

WD contact info:

I’m very new here and hesitate to jump in, but I found that if you want to transfer a lot of files, it’s easier and faster to do so directly from the source drive to you my cloud. First connect the my cloud to your computer not to the router. Log onto my cloud as a guest . Then open your source drive the drag and drop the files you want to have in your cloud.

Tried that.  Same result.  Contacting support.   thanks