Repurpose NTFS hard drive for My Cloud EX2


I bought a My Cloud EX2, thinking I could re-purpose a couple of WD 1TB drives that I had kicking around.

I was using these drives in a Windows environment so they are formatted NTFS (I dont mind/need the information currently stored in them though).

However when I inserted one of these drives in the NAS I can’t format them.

First, I tried the GUI > Settings > Utilities > Format but it’s grayed out, so no go.

Then I downloaded and tried WD’s “My Cloud EX2 Setup software”. It detects the NAS and check marks the drive as soon it’s inserted, but when I click “Format” it stays at 0% for hours (even overnight). No progress.

Also when I power up the NAS diskless, the power LED is steady blue, but after I insert the drive it goes flashing yellow and the drive LED goes flashing red.

I know the disks ar OK, I was using them in other hardware. Is there any other way to format these drives to be used by the NAS?

Welcome to the Community.

What are the specifications of these hard drives? As a recommendation you could try writing zeros to the hard drives to destroy the partition table and file system, making them behave as new drives.

One drive is a 1TB WD10EARS (green). The other is a 2TB Seagate Barracuda.

Any recommendation for a tool that could write zeros to the whole disk? If using Windows command line format with option /p:1, what /fs: option should I use {FAT | NTFS | exFAT | UDF}?


Here you go:

On the other hand, different hard drives may be incompatible in a RAID array. This could very well be the problem here.