First time user, NO DRIVES found, please help! can't map the drives either

I bought the WD Mycloud today, I have a really urgent project I need to attend to so would really appreciate some fast help.

I thought it would be as simple as buying the product, then removing my external hard drives (from external drives I currently have) and inserting them into the WD housing and I would be able to access them over my home network. Turns out I can’t, is this because I need to format the drives in a specific way? They have data on, one 4tb and one 2tb so I have no way to back them up. There is a light flashing on it that is yellow, it also says it isn’t a RED NAS drive that I have inserted, can;t imagine it’s only compatible with those drives?? I tried to map the drive via the network but it can’t se any drives, so think the main problem is my drives aren’t registering. I took one out and tried with a single drive and still nothing. Any help would be excellent thanks again!

Realised I didn’t mention, am on windows 8.1, on an ethernet connection to my home network.


hi there.

What you did will not work on WD ( and i believe on any NAS ). The EX2’s OS is on a flash memory and it will be installed on the pluged in drives.

You need clean ( or ready for format) HDD in EX2 and then you can copy the files there.

Hi there,

Thanks for the reply, much appreciated! 

Think it’s down to my lack of knowledge about NAS drives… so it’s not really like an housing for existing data? … it’s basically a clean setup that will enable me to backup files, once it’s installed and up and running right?

So technically I need to buy two clean drives, install in the EX2, then plug in via usb my other drives and download the data is that right?

Thanks again!

Yes, you are right. Unless you can copy the existing data from the drives to a pc or something, then format the drives and plug them into the NAS…that’s pretty much the workaround.
But you either connect the external drives to the NAS’s USB or to a pc and then copy the data via network.

sorry wrong answer

Are you sure you bought a WD My Cloud? or another WD product? The My Cloud is not meant to be taken apart.

Thought the same thing at first, but aren’t the EX versions capable of swapping hard drives?

The My Cloud EX series forum is here.

1 Like

Ah thanks sorry it is the EX version, any ideas what could be going on? Thanks for the speedy reply!

If the drives were connected to your windows 8.1 system.  Then they don’t have a linux system on them.  Didn’t your

ex come with drives already in it?  If so put them back and get the my cloud working.  Then put the disks back on your windows system and copy the file over.


Hi there,

No I bought an empty ex2, so I could just stick my 4tb and 2tb in there as a central location for all my storage.

I can plug in an external drive via a usb and that is seen perfectly, so must be some compatibility issue… but in the manual it says I can use drives that aren’t RED… so am confused.

You need to log into the web dashboard and format the drives. I’m not sure it will allow drives of different sizes, but either way, it WILL erase your data from the drives.