Remote Access

I got a new router and (as expected) ran straight into trouble (I thought the ac might be worth it). Problem is, that this model does not support UPnP to punch holes in the firewall. I found the manual setup steps and enabled port forwarding, and now everything looks fine, at first:

  • WD’s Dashboard displays successful remote connection

  • WD2go shows my NAS

But: it does not work. The iOS MyCloud App (successfully connected via WLAN; I also tried a new setup from external network with activation codes) works only up to NAS identification, but cannot to access it. Curiously, in the dashboard there is a question mark displayed next my connection, but the status is connected.

Does anyone have any troubleshooting ideas?

Found this:

I’ll troubleshoot around the steps 4) and 5). Great guide, btw!

It was indeed down to my telco’s router’s integrated firewall. While I could set up a port mapping, it simply didn’t work. Once I stuck to the well-known ports and just forwarded 80 and 443, it worked like a charm.