Redneck Guide to Docker 20.10.14 on OS 5

This is by no means the best way to go about getting Docker 20.10.14 running on your device. I also leave out some of the specific instructions on how to turn on SSH, use the terminal, etc. Please refer to the forum search and Google for further assistance on these topics.

  1. Download the bin file for your device from the link below:

Release Docker v20.10.14 for WD My Cloud · WDCommunity/wdpksrc · GitHub

  1. Upload/Install the bin file through your NAS’s website in the app section

Note: Recently I updated my Docker container by uploading the most recent bin released by the Great @JediNite - big thank you!

I have ‘hidden’ the below steps as I did not find they were necessary; however, if you encounter a problem, check them out:

Summary

Using FileZilla to SFTP into your NAS, replace the files in

/mnt/HD/HD_a2/Nas_Prog/docker/docker

  • with the files from docker-20.10.14.tgz from the link below:

Release v20.10.14 · JediNite/docker-ce-WDEX4100-binaries · GitHub

  1. If Portainer will not load from port 9000, you will need to change the port. Since this was a new setup, I deleted the below folder.

/mnt/HD/HD_a2/Nas_Prog/docker/portainer

  1. I then modified the update_portainer.sh in the below location

/mnt/HD/HD_a2/Nas_Prog/docker

  • I made the following two changes in the shell script to do two things: (1) update to the latest version of Portainer; and, (2) open up port 9001 and redirect traffic to 9000 so that the container is accessible locally from our browser.

docker pull portainer/portainer-ce

docker run -d -p 9001:9000 --name portainer --restart=always -v /var/run/docker.sock:/var/run/docker.sock -v $(readlink -f ${APKG_PATH})/portainer:/data portainer/portainer-ce

  1. After you upload the new version of the file, run the script by typing in

sh update_portainer.sh

  1. You should now be able to visit [your NASs IP]:9001 to setup your Portainer. If you do not do this, you leave your entire NAS wide open. Also, don’t forget to turn off SSH…
5 Likes

Can you explain how @dswv42? Maybe we can get an app version setup to skip all these steps!

For the first time I am thinking about doing Docker again on my other non-WD NAS

If you want to read up there are more active user groups in the other NAS forums


comments directed to ActiveUser – I blame the reply button :slight_smile:

Hey @ActiveUser,

To be honest, I had been leaving the package builds to @Tfl to do and I had been focusing on making sure that each new docker release is available for the arm NAS units on my Github repo. On my own NAS, I actually don’t bother updating the binary for the installs and instead as each release comes out I create a new docker folder (eg. docker-20.10.8) and then create a symbolic link from this folder to a folder called “docker”. When a new release comes out, then just need to stop docker, remove the symbolic link, point to the new folder and restart docker.

I know this is probably not the answer you are looking for.

Cheers,

JediNite

1 Like

Thank you @JediNite for the reply! I’m just glad to hear from you. Having the latest binary on Github is awesome in of itself.

Appreciate your insight into upgrading. This seems like a simple enough solution to updating Docker. It would be great to get this into a guide - for novices like myself…

Great guide, thank you, worked like a charm!
No-one was more surprised than me to see the logon screen appear in my browser!
BUT, one problem, if I try adding a new Environment in Portainer, I get an error message “Failure / xxx url xxx / ping EOF”.
Any idea how to fix this?

I’m sorry to report I have no idea - I truthfully know very little about Docker. Have you tried googling this error message to see if others have encountered it?

And a new and worse problem!

I now can’t access the Portainer logon screen.

If I go to My IP:9001 in whatever browser, I get “Page cannot be found.”

Have rebooted the box, the docker app is running in the WD GUI (although the “Configure” button doesn’t work as it seems to be aimed at Port 9000), I can access all docker/portainer files via WinSCP.

Just no logon screen. It worked fine for about a week and then disappeared. Halp

*SOLVED: Portainer needed a reboot by running update_portainer.sh

Interesting find and glad you found a solution.