RED light top, and blue lights bottom. No connection with My Cloud Mirror

Hi, I have a my cloud mirror 2x1TB - it has been working fine.

Red light showing at top
no connection to Mycloud via laptop, Ipad, iPhone or online cycloid website.
IP network scanner finds the device connected to my network but its identified as network camera! when trying to connect to the IP address given, directly through browser it will not connect/load. although the WD logo comes up in address filed.
Things tried so far::confused:
unplugging the device and reconnecting after some time
holding in the reset button for 10 secs

Can anyone help?
much appreciated, thanks :blush:

Hi, you can try connecting the drive directly to the computer and also doing the 40 seconds reset.

Hi Thanks IIuna… actually I tried that but it didn’t work… I then tried swapping ethernet cables because the one i was using was quite old and worn… it turns out that the problem was related to the faulty ethernet cable!! thanks for your suport.

Solution: changing faulty Ethernet cable and ensuring the connection is good.