RAID degraded, but disks healthy?


#1

I rebooted my MyCloud Mirror (Gen 2) via the dashboard and when it came back up I received a warning that the RAID was degraded (that error wasn’t there when I rebooted from the dashboard earlier) yet, when looking at the disk status, both drives show as healthy. I ran a disk test and everything came back fine, so I rebooted again to see if the error would clear, and it didn’t.

I went to manually rebuild, clicked “next” to begin the rebuild, the drive self test ran (it came back “good”), and then I clicked “finish”. “Updating” briefly hung on the dashboard, then went away, and nothing else has happened. What am I missing here? Does the dashboard not show how much time is left for the rebuild?

Additionally, I’m seeing some inconsistencies in reporting: the dashboard shows 2.15TB free, yet the RAID volume is showing as 3.93TB (this is on the 4TB NAS).

UPDATE: So, since nothing appeared to be happening as far as a rebuild, I ran a full system test (which came back fine), followed by a full disc check (which came back “Disk1 Failed - Full disk test failed. Please backup your data and replace this disk”). I’ve barely owned this for a year (I ordered it on 2/3/2018), and now I have a catastrophic drive failure? Given the limited use (I’m the only one who uses it, so there’s rarely any concurrent connections) I’m at a bit of a loss, unless WD sent me a NAS with bad drives (this was a refurbished model).


#2

The internal drive of the My Cloud Mirror Gen 2 Enclosure may have gone bad. If the full system test shows that the Disk 1 has failed. You can try creating the RMA of the internal drive from the link given below, if under warranty.

Otherwise, if you are using the device in RAID 1 configuration. You can replace the Bad Internal hard drive with the same hard drive and Rebuild the RAID. In this way, your data will be saved.


#3

Looks like a complete drive failure despite the MyCloud barely being a year old, and without any warning signs.

Not too sure what to think here. I’ve never had issues with WD drives, I have friends using WD drives in their Synology NASs (under heavy load, compared to my nominal use) without issue, etc. Given that the Dashboard showed that both drives were healthy, and simply rebooting the MyCloud ended with a catastrophic failure leads me to believe that the weak link is the MyCloud software (wouldn’t be the first time the Dashboard blew up the MyCloud).

I overnighted a replacement HD to get things stable, as well as an external drive to make a secondary local copy (in addition to my remote copy), and am now working on getting a warranty replacement drive (will use that to replace the other drive, just to be safe). Once this is all taken care of, I’ll be looking to replace the MyCloud with a DS218+ since I’ve had nothing but trouble with how the OS has preformed.