Quick View Missing after restarting windows

Just realized how bad my title line was.

Just got replacement MBL. Now Quickview missing


4 hours ago

Got my replacement today. I’ve hooked it up and ran the Setup CD and following the prompts mapped the drive and installed Quick View but not SmartWare. I don’t need backup and I’ve heard it was no good. And my experience of it last time was upsetting as it wouldn’t start, uninstall, or install. So everything seemed OK so I shut the computer down and went out for a coffee. When I started the computer up again QuickView was missing. The icon is there but no access to anything but “about”. I clicked on QuickView in ALL PROGRAMS in Windows XP SP3 .Net…3.5 but nothing changes. I can get to the drive through Mozilla at the html address.I enabled SSH as suggested. I also installed the drive on my laptop and QuickView is present when the Setup CD is being used but when I reboot it’s gone with no  menu.

Is this normal and if not can I fix it?

Do I need Smartware for it to work?

Can I turn Twonky off as I have no DLNA enabled equipment?

Can I turn ITunes off as I have no I things?  I’m getting an IPhone and the Grandbrats have I everything.

Should or shouldn’t I update the firmware?

1 Like

When you only install WD Quick View - you will see the quick view icon in the taskbar.  If you place the mouse over the icon - you will see your MyBook Live drive listed - and hopefully it is showing a green status.

If you click or right click on the icon in the task bar - you will see your drive listed with an arrow next to it on the right.  Click the arrow to see a list of options that can do with the drive.

The only other option you will see listed along with the drive - is the About option.

If you aren’t seeing your drive with either a green (good) or red (bad) status - then something is wrong.

The lastest version of WD Quick View and Smartware is available on the WD Site under support - downloads - choose the MyBook Live drive - download the ISO CD image - burn it to a CD - and reinstall WD Quick View.

If you don’t plan on using Twonky, Itunes Server or Remote Access - then disable all of those features from the MyBook Live DashBoard.

If you are not on the latest firmware - I would suggest upgrading to the latest firmware.  Before you upgrade the firmware - make sure that you have SSH enabled - and Twonky disabled.

FYI - You really don’t need the Quick View or any of the software on the install disk.  You can do what you need to do from any browser by opening the dashboard at http://MyBookLive   (assuming you drive is named MyBookLive)



If you aren’t even seeing the MBL listed in WD Quick View (underneath “About”) - are you able to actually open the MBL’s dashboard from your browser on that specific computer.  If you can’t get to the dashboard from that computer - then that means that the MBL is not visible on your network - and that is a problem outside of Quick View or Smartware.  I would suggest verifying that the PC can actually see the MBL on the network before reinstalling.

Also - open a command prompt and enter “ping mybooklive” - if ping doesn’t find it - something is wrong.  You can also try to ping the MBL via its IP address directly “ping xxx.xxx.xxx.xxx”  - you’ll need to know what IP address the MBL is using to do this.


Thanks. Yes I can see MBL through the dashboard in the Mozilla browser and can change any setting. I’ve loaded music on it and played it from the computer and laptop through the Explore or desktop shortcut. So the only thing missing is Quickview as there is nothing but the about box, no mouse over menu no temperature thing…nothing.

The other odd thing is the QuickView installed on the laptop was from the previous install with the old MBL that I returned.

Before I ran the disk and did the discovery it showed the MBL. It wouldn’t install a new version because it was there already.

Can it have something to do with the drive letter being Z  ?

I’ve enabled SSH and shut down Twonky. Then I applied the Firmware update via the web browser dashboard manually and the Quickview menus came back. It worked perfect on the desktop and the laptop.  Good advice! Thanks   Jim

Glad to hear that it is now working.  Depending on how old the firmware was on the replacement MBL that you received - could have caused issues with Quick View.  One issue that I had on earlier firmware was that quick view was reporting that the drive was overheating - when in fact the drive was running just fine.  Updating the firmware fixed that.

Also - beware of the software CD that ships with the MBL - as well as the software install included in the Software folder on the MBL - there is a much newer version of the software CD (a new iso image) that you should download and burn to a new CD - ignoring the CD that came with the drive as well as anything in the Software folder.

The new version of the CD corrects some issues on both the Windows and Mac Platforms.


Thanks again! I’ve downloaded the new install iso and will burn it tomorrow.  Jim

Well, here we go again. The Quick View menu is gone again but web access still works.  I’ve burned the new version from WD Support and it won’t Discover my drive. The firmware upgrade only worked for a while. Egad! This is as bad as my ongoing head gasket failure on my Montana minivan, which they wouldn’t admit to either. Now they don’t make minivans anymore. Will that happen to WD with NAS? I know I’ll never buy GM again. And it cost me $24 to send back my first DOA drive.

Quickview is back? I’m listening to music from MBL, maybe that’s it. It was gone while transfering though. Jim

I don’t think this is a problem with the MyBook Live - it sounds more like it’s the particular PC/Laptop - or your network.  I downloaded the CD inmage a few days ago and installed on a Windows Vista laptop (with a wireless connection) - and ony installed quick view - and it works just fine.  The first attempt at discovering the drives (I have 2 MBL’s) failed - I kept clicking on the discover process and then it finally found one drive - and then all was fine.  I assume that the delay in discovery was due to the fact that the MBL was sleeping and had to spin up.

How is your PC connecting to your network - wired or wirelessly?  Can you pull your MBL off the network and plug it directly into the ethernet port on the PC that is having the issue?  If you still have the problem with the MBL directly connected - then the problem is either the PC or the MBL - if it works directly connected - then the problem is either your network or your wireless adapater in the PC (assuming you are connecting wirelessly).


You may also want to check your router configuration to see if there are any security type of settings that would prevent the MBL from being discovered - specifically those related to DNS.


Thanks.  I have an old tower I built running an Athlon 2100, 1G dual memory on an Asus motherboard with a 1g lan built in. Just got a Net Gear WNDR 3800. I’m running wired at  1Gbps. I just tried again and it discoved the drive but said Quickview wouldn’t install because it was there already. I saw no option for upgrading. The wireless laptop has no Quickview and I’m playing music on both of them.   Jim

Everything is default on the router as I just got it and I’m learning.   Jim

What is the brand and model number of the router?

Netgear WNDR3800 N600 Wireless Dual-Band Gigabit Router - Premium Edition

Thanks for the help guys but I give up and I’m trying to get a refund.  Jim

I’m having this exact problem, and my router is also the Netgear N600 WNDR3800. I’m wondering if there’s some configuration setting in that router that’s contributing to this. My previous router, a D-Link, worked flawlessly with the MBL, but it died a week ago. Shortly after I installed the Netgear my Quick View popup disappeared except for the “About WD quick view” message. I uninstalled and reinstalled Quick View and it was initially working, but after a day it’s disappeared again. I can access all files on the MBL, and logging into the UI, using either the IP address or the mybooklive URL, works fine.

The Netgear 3800 is my new router. It didn’t work with my old netgear router or my Dlink router. It didn’t work before or after I upgraded the firmware from a file. It also didn’t work on my laptop. I think it is a combination of the software and the firmware and maybe XP makes it worse.  Jim

After re-reading your post closer I remembered that my D Link router wireless part died after I used it with the first MBL  that I returned. Also my old Netgear was really messed up too and this was posted  as well. I bought the N600 for the Gigalan hoping that would help. Loading the MBL full of songs was fast but nothing else worked. So I’ve sent it back for a refund which WD graciously accepted.

Just out of curiosity - did you ever get a chance to plug the MBL directly into the ethernet port of the laptop in question?  If quick view works with the MBL plugged directly into the ethernet port - then this would be a strong indication that the problem is caused by some setting in your router (since in this scenario the router would be out of the picture) - provided that you disabled wireless on the laptop before testing.