Question about formatting my G-Raid with Thunderbolt

I recently had to format my G-Raid with Thunderbolt 8GB (for Mac) After formatting I have ended up with 2 4TB drives showing up on my desktop. So I have lost the Raid aspect of the drive. How can I get it back into the format that it was in when I purchased it?

Hello BWJR,

The reason for this is because the G-RAID you have is a softwareRAID product. Meaning Apple controlled the RAID with Disk Utility. By formatting the drive outside of the RAID process it will split the drives back into being essentially a JBOD (Just a Bunch Of Disks)

This is likely due to being on Mac OS 10.11.x El Capitan. Apple removed the ability to manage RAIDs in their Disk Utility with the newest version of the Mac OS.

You can restore it back to a RAID with an older version of the Mac OS 10.10 or older or you can use the Terminal on your system to do it manually. There are a few articles out there that have been created because of this issue with El Capitan. HERE is one that we recommend.

Thank you very much! I have never used the terminal before just followed your instructions and read the article and it worked.
Thank you so very much!!


Hey everyone. I’ve recently purchased a G-Drive RAID 8 TB with Thunderbolt 2 and USB. I bought it to predominantly use it in RAID 1 mode with my MacBook with USB-C. I thought setting it up in RAID 1 mode was a relatively easy process, but from what I’m learning is that Apple has stripped this ability from the macOS – even though i do see a RAID option in the macOS Sierra Disk Utility, it doesn’t seem to work.

I reformatted the stock drive when I got it and wanted to try my hand at using the macOS terminal. However, what I’ve noticed is that there are two drives shown in the TekRevue tutorial referenced in this thread whereas for me, right now in the macOS Disk Utility, the G-Drive is seen as one unified drive, as shown here:

I’m very much a novice to all of these things so would appreciate any feedback or advice you all have on setting this up in RAID 1 mode. I don’t want to use any piece of third party software like soft raid because I prefer to use stock apple feature, especially when considering i want this drive to work on multiple devices.

Thanks a lot,


The drive you purchased is not the same drive as this thread is for. They have an older version of the G-RAID w/ Thunderbolt 1 and no USB.

It is a software RAID device. The one you purchase is a hardware RAID device and we have a configurator on our site to convert it. G-RAID Removable w/ Thunderbolt 2 & USB

I have the opposite problem as the OP. My 8 TB with Thunderbolt came configured as RAID 0 and I want it to be JBOD. I tried erasing the drive with Disk Utility, but that function fails every time. Can you tell me another way to get this drive to be recognized as 2 separate drives?