PS3: "The data type is not supported"


#1

I’m having an issue using the TwonkyMedia server in the MyBook World Edition with my PS3.

I have videos that play on my PS3 via a USB thumb drive.  They also play from the MyBook through an additional media server (PS3 Media Server) running on a computer (with transcoding disabled).  However, when I try to view the same videos directly from the MyBook, it get a “data type is not supported” error.  I’m confident there must be some sort of compatibility issue between the TwonkyMedia server on the MyBook and my PS3, but I don’t know how to resolve it.

Anyone have any ideas?


#2

What format or container are your files in that you are having the issue with?

I’m suspecting you’re going to say .mkv?


#3

Hello

I’m getting a similar problem, some avi files i have on my mybook work fine but others give the “this data type is not supported” error message. I’ve tried these files using PS3 Server and also by loading them onto a memory stick and they work fine.

Any suggestions?


#4

I occassionaly have the same problem as well.  What I have noticed however is if I access the Twonky server and “Rebuild the database” those files start playing on the PS3.

It’s a PITA however to have to go in and rebuild the database everytime I add a file to the drive.  I’d like to know if there is a way to have the Twonky server “automatically” rebuild the database when I add something, or…  at the very least like once a day or something like that…  anyone have any ideas?


#5

Same issue here. On one occasion I changed the file name, from (for example)

legaldownloadfilm.HD.Pp123.HD.avi

to a simpler name

legaldownloadfilmHD.avi

With some success - though not 100% time. I’m not sure also whether I changed the file name BEFORE I sent the file to the WD or before, while it was still on the Macbook. I’ll have to try both. i’ve read elsewhere that changing the file extension from .avi to .mpg may help too though I haven’t tried this yet.

Bizarrely on another occasion I’ve noticed a file working on it’s own a day or so later…

Bizarrre - and kind of annoying.


#6

CNPalmer:  No, I’ve learned my lesson with MKV files; plus, MKV files will not play no matter how they are delivered to the PS3.  These are both AVI and MPG files that play perfectly on the PS3 via USB or 3rd party UPNP server yet do not play via the built in UPNP server on the drive.  

What’s the point of having a networked UPNP drive if I have to have a computer running an additional UPNP server to get to my media?


#7

I actually posted a related issue a couple of days ago. If I upload files from my mac I get the filetype not supported, but if I uppload the same file from PC, it plays without issues! If I download a Mac uploaded file to the PC and re-upload the same file it plays without errors!

If the files are uploaded from Mac using third party software all files play directly!

I find this behaviour extremely frustrating. Any ideas as to why some files do not play back one time, but by some annoying fiddling with the file it will play without any real modification! They all have identical properties and rights!


#8

Rebuilding the library makes these files playable, not refreshing, not updating but rebuilding. And yes this takes a while, and yes this is ****** annoying! But this “solves” the problem I’ve been having with my files…