Problems with Network share and how I solved it

I want to share my problem and solution to not beeing able to open Net work share since it is such a common problem.

I have a DIR-100 router which I connect by wire to my PC, my Sony TV and my WDTV Live player.

WDTV player settings


Subnet mask:


DNS:              [Deleted]

Firmware 1.06.15V

I could not understand why so many had network problems. My WDTV Live worked without any network problems.

After 8 months, suddenly it was imposible for me to open Network share and reach Internet.

I had not changed anything. No new firmware was loaded as I remember.

The player had an erratic behavour. One morning everything worked OK. When I started playing a video through the network, the video suddenly stuck and I had to disconnect the player.

I couldn´t reach the network again.

I tried everything which I could find and understand on this site as Restoring factory defaults (That command actually solved my problem for one session) and other advices on this site. When checking connection, the player got stuck on DNS adress.

I pinged the device from my PC (ping and got a response.

When I pinged on the name I did not get any response. (ping wdtvlive)

Thus I confirmed that it was a DNS-problem which was to complicated for me to solve. There is a lot to be read about this but I am not an expert.

The solution for my problems were actually very simple.

After trying restoring factory defaults I also performed the reset by pressing a paper clip in the small hole close to the USB connection on the player for a second.

I found that advice on this site and want to express my gratitude for that.

Now everything is working.

I can also ping on the name " wdtvlive" and get a response.

Conclusion: My problem was caused by something in the player which had changed.

Resetting by the paper clip solved my problem.

Now I can even reach Media server which has never worked before.

I can however only reach my C:disc. Photos and videos are on my D:disc which makes the Network service unusable.


1 Like

asaleo, thank you very much for sharing your experience with the WD Community, I hope for several Users to be assisted by your contribution.