Problem with links and image previews using browser

Hello! Two things, when I right click a folder or file to get the sharing link, it opens up the dialog to input an email, when I try to skip sending an email and hit the get link button, it copies a non functioning link to my clipboard.


In order to actually get the correct link, I have to send myself an email using the box, and then copy the correct link from the email that I can send to my friend.

Secondly, when I share a link to a folder of images, there are no image previews for the files. Each of my photos are around 14MB. Does that have something to do with it? In this case, users have to download an image before they can even see it, which I guess could be annoying for some that just want one image from the folder.

Just wondering if these two points are active issues or current suggestions or whatever, Thanks!

I take it you are on I tried this and did not have any problem with the link it gave me. I copied the link and went to my SeaMonkey browser and opened the folder without any problems. Why don’t you send your friend a private e-mail link for the folder. See image below. Click, tap or activate image to enlarge it.

When I opened the link I was given there were small previews of the photos.

Have you checked your e-mail to see if there is a size limit on what you can send?


I’m talking about links obtained using the desktop client, I’m on a Mac computer. And yes, I use to access via the browser on Chrome/Safari.

There’s no options on the desktop client to configure what kind of link goes out.

And I just double checked, still no image previews on my files. Anyways I just started uploading a week or so ago, maybe it takes longer to get image previews working? Idk…

Here’s some screenshots of the issues on the browser on mac and mobile app on android. -

Is there a place somewhere with all bugs listed? I’m sure this can’t only be happening to me, my friend that I sent the link to said they also couldn’t see any image previews.


forwarded this to support…

hi there,

I got the same problem.

Did you solve the issue of previewing the jpg file?


This thing takes so much time to troubleshoot, I’ve almost given up on working with support. I stopped trying to fix these issues as I’ve begun to have bigger problems with the device, but if I get it solved I’ll reply.