Problem: WD Myclound not visible on wireless network

It seems no solution has been yet proposed for the visibility problem. I have been suffering from this problem for a while.

My question now is: anybody found a solution? In particular, my problem is that WD Mycloud is not reached through my wirleess reouter connection.

Here is what is happening:

  1. In the past, I had a router (Operating on ADSL), which is wirless and wired. I linked WD cloud to it. The router (which is also a modem) was connected with a Desktop PC. I have a laptop connecting to the wirless router, hence to the WD Mycloud without any single problem.

  2. I have given up the ISP and brought a wirless router. Because of poor signal, I have to put the router near the window of another room. It is not possible, therefore, to wire it up with my PC.

  3. So, I brought a switch and connected it to an access point. The access point receives the router’s signal and commnicates it with the devices attached to the switch. Thos devices are a printer , the WD mycloud and the PC computer.

  4. I have had lots of problems. The PC sometimes detects the WD but other times (when the power is off then on), it does not see it at all. My problem is the same with the laptop, which does not see the device.

  5. After thinking on the matter, for a while, I deduced that the main problem is that  whenever the router or the computer is turned on then off, the network assigns a different IP to the MY clould device.  I solved this problem by getting into the dashboard of WD cloud and fix the IP to STATIC. I chose an IP unlikely to be in conflict with other IPS, that is: 192.168.1.20

  6. Now:

(A) The PC works fine with the WD Mycloud. There is no ptoblem even if I restart the PC or turn on and off the PC or teh router. Since it is connected to a switch and through the switch to the WD Clould, (By wire), it can see it.

(B) My Laptop does not see the WD Cloud through the wirless router. The only solution left for me is to connect the laptop by a  wire to the switch. In this case, it works.

©  When connecting my laptop with the wireless router,  I am unable to reach the WD Dashboard. The IP Does not work. The problem seems to be that: the router goes to the internet in search for the WD local address 192.168.1.20 instead of going to the switch.  As a result, the router does not see the device and the devicse is invisible in the network.

So,  if my deductions are correct, my question is: HOW can I make the wirleess router go to the local address instead of looking for it in the internet?

I’ll venture a guess…

It sounds like your WIFI is not on the same sub domain.

Just check to make sure you got almost the same IP except the last set of numbers… The DHCP should assign everyone with 192.168.1.xxx and the subnet mask should be the same 255.255.255.0

You static should be outside the dhcp range like 192.168.1.199 and the DHCP 192.168.1.xxx range should be only assignable within 1 to 190 thus 192.168.1.1

good luck…

Thank you!

What should I exactly change? I understand you mean that I change the IP of my laptop (which has the problem), but how?

Just make sure your laptop is using DHCP to acquire an ip from your router that assigns ip in the same ip network as your cloud. Check that your static ip is in the same network as your dhcp assigned ip; if not then you really have to change everyone starting with your static IP cloud and onwards. 

You can also assign a static ip on your laptop to be similar (not same ip) to your cloud…

To learn how to assign ips to your laptop use google to find out how as I don’t have my PC open right now.

So far, so good. I followed your advice and did the following:

run CMD

type: ipconfig /release

It released the laptop’s address and assigned another one.

Surprisingly, the Z drive (which correspinds to Mycluod) has worked through the wireless network.

I need now to chek by doing the following:

1-restart laptop and see if it is ok or not

2- restart the router to see of it is ok or not