PR4100: Music files on PR4100 unable to be found by Pioneer N-50K network streamer

Dear all

I have a PR4100 (running OS5), which is used solely as a media hub, primarily serving video and audio through the PLEX server software (on the PR4100), to the Android PLEX app on my Sony TV.

However, I want to be able to connect my newly acquired Pioneer N-50K network streaming hi-fi separate, to the music folder on my PR4100 NAS device, so that I can stream the music into my home hi-fi system.

At the moment, whenever the Pioneer streamer searches for folders anywhere on the network, it doesn’t find anything. It is connected to the router (and wider internet) correctly, and streams internet radio stations just fine.

There appears to be some settings that I might need to change on the PR4100 NAS, so that the two devices can talk to / find one another. Pioneer tell me that DHCP must be enabled on the PR4100, and at the moment, this doesn’t seem to be enabled.

On the network services tab of the PR4100, IPv4 is presently set to “STATIC”, and IPv6 is set to “OFF”. I had done this, so that other computers on the network could access the PR4100 as a mapped network drive (which wouldn’t jump about with changing IP addresses) and be able to access all of the media files whether through PLEX (also using PLEX on the individual computers) or not.

When I attempt to change IPv4, it takes me through a set-up wizard, but I don’t know what settings to change them to, so that it doesn’t interrupt or affect the ability to stream to PLEX apps (on TV and networked computers), but so that the Pioneer streamer finds it on the network, so that I can stream music files to it.

At the moment, I have: MUSIC, FILMS, TV etc set-up as core main files in the root directory of the PR4100, so it should be ready once the Pioneer streamer can find it.

Many thanks for any replies

Hello there

Many thanks for replying. I’ve just updated the settings and tried it again, but sadly, it didn’t make any difference. :frowning:

I’ve just taken some screenshots of all of the settings from the PR4100 network settings, and uploaded them below. Is there anything else that needs to change?

It occurs to me, that the NAS is password protected, and, for example, when adding the NAS as a networked drive in Windows, the admin password needs to be typed in as part of the process before the drive is added. Within the Pioneer streamer, there is no such facility to add, or type, anything at all! I had wondered if the security of the NAS itself is blocking the Pioneer streamer from being able to find/access the files and folders within it?

Many thanks

Thanks for this. I have just checked, and the PUBLIC toggle was already set to “ON” already - sadly, this isn’t the problem either… :frowning:

Apologies if I’ve caused us into going off track to finding the solution!

Have you read the user manual for the Pioneer N-50K? If I’m reading the correct manual; Chapter 7 - Music Server, indicates one option for network playback is to use the DLNA media server on the network storage device to stream music to the Pioneer N-50K device. If this is the case, then you would need to install the Twonky Media Server app in the My Cloud Dashboard App tab. Then enable and configure the Twonky Media Sever. Depending on how Twonky works in OS5, one may need to ensure each Share containing media is scanned by Twonky for media.

My Cloud OS 5: Twonky Server Configuration and Settings

Edit to add: If one doesn’t want to use the Twonky Media Server one could see if that Pioneer device could use the iTunes Server app one can install through the My Cloud Dashboard App tab to stream music from the My Cloud. See the following WD Knowledge Base Article on how to install the iTunes Server app in OS5.

My Cloud OS 5: How To Install 3rd Party Apps

Edit to Add #2: If you are using Plex currently then, installing the Twonky Media Server isn’t really needed. Instead one can enable the DLNA Media Server within Plex and see if the Pioneer N-50K can stream that way.

Hi Bennor

Many thanks for this helpful reply. I’ve been buggering about with trying to get this to work for a few days now, and am simply not making any progress!

PLEX is installed, and is working fine. I have followed your suggestion, and ticked the “enable the DLNA server” check-box. Sadly, it made no difference.

I have spent some time installing and then attempting to get TWONKY to resolve the issues. I have TWONKY running, and it is finding devices on the network, as can be seen in the image that I will upload below, but try as I might, it won’t pick up, see or find the Pioneer streamer! I don’t understand why!!

Also, as can be seen, I can reach and visit the Pioneer streamer, at it’s IP address, using a browser, so it is on the network and findable. I can also see the Pioneer streamer in the router ARP table as well, so it’s clearly on the network. As far as I can see, I can’t force TWONKY to enable or visit a device at a specific IP address, to “force” the device find?

I can’t see what I can do next… so frustrating!

Also… I think I’ve correctly set up and saved the “SHARES” on the TWONKY server. It has found 22k music tracks, and seems to be showing them all correctly as far as I can see. I am, however, slightly confused as on the 2nd image, in the dropdown menu, I seem to be able to select either the TWONKY server as the source for music, or the PLEX server (at least TWONKY is finding the bloody PLEX music server!):

You don’t use Tonkey to “find” the Pioneer, you use the Pioneer to find Twonky or Plex or another local DLNA media server. Per the link to the Pioneer user manual posted above (assuming its the correct one for your device) the general process to play music from a local network media server is as follows using the Pioneer device and it’s remote control:

Playback with Music Server

  1. Press Music Server to select Music Server
    You can also perform the same operation by pressing the FUNCTION on the front panel repeatedly.
  2. Use Up/Down to select the server that the file you want to play is stored on, then press ENTER
    The folders/files stored on the server are shown on the display.
  3. Use Up/Down to select the file you want to play, then press Enter.
    Playback starts.

Edit to add: One troubleshooting step is to ensure both the Pioneer and the My Cloud are in the same local network IP address pool. One may have to check their local network router’s DHCP server to see what IP addresses are being handed out to the various local network devices and ensure they are all within the same address pool.

Hello Bennor

Thank you taking the time/trouble to upload the relevant page of the Pioneer manual. Everything that you’ve said is correct as per the manual, however, as per my OP, I cannot get past Step 1 of these Pioneer instructions, as when you press “Music Server” - it simply says “Please wait” on the display of the N-50 streamer and goes no further. I am completely unable to go through Steps 2 or 3, as no folders are found.

As per my previous post - TWONKY does not find the Pioneer device either. From my reckoning, TWONKY does find devices, as each time you press the button the refresh the list, it often changes. Either way, and what’s crucial here, is that the Pioneer device is never found and listed in the TWONKY device list, which makes sense to me, as the Pioneer device is finding the music server either…

Therefore, I can’t even see what I might need to change, update or adjust to make them each other?

Generally Twonky will list the devices that connect to it, not the other way around. If the Pioneer cannot see and connect to it, then generally Twonky won’t list it in the Devices section(s).

Due to the age of the Pioneer N-50 it’s possible it doesn’t support newer network protocols. As such one may have to adjust the My Cloud SMB and NTLM values in the My Cloud Dashboard > Settings > Network > Windows Services, if one hasn’t done so already. Try adjusting the SMB and NTLM settings to include SMB1 and NTLMv1.

My Cloud OS 5: Change Windows Samba (SMB) Protocol Version

My Cloud OS 5: TV, Printers, Scanners, IP Camera and Media Players Cannot Connect

Thank you for this suggestion Bennor.

The NTLMv1 was already set to included v1. However, the SMB wasn’t and was changed. Sadly, it made no difference… :frowning:

I’m also getting some help from Draytek, as they make the router and extender equipment that I use. I can see the N-50k in the ARP cache of the router. I can visit the IP address and see the Pioneer welcome page of the N-50k by going straight to it’s IP address. It’s just TWONKY / PLEX that cannot see it!

Another troubleshooting suggestion. Take the My Cloud out of the mix by configuring Windows Media Player 11 or 12 on a Windows PC, or iTunes 10.1 or higher on Windows or Mac PC’s to share or stream media on that computer/PC to other devices (like the Pioneer N-50K) on the local network. That may help to possibly narrow the problem down to either the Pioneer device itself or to a possible networking (or router) issue.

Also, if one is using network extenders (wifi extender, power line network extenders, etc.) or a “mesh” system, with the My Cloud or Pioneer unit connected through an extender or a mesh node and not the main router. One may want to look at the settings for those extenders or mesh systems. Sometimes network extenders/mesh systems will block devices from communicating with each other (often called “client isolation”). One may have to ensure such options that block client communicating with each other are disabled or turned off.

Thanks Bennor

My gut is that the router/extender is at the heart of the problem here. I have a Draytek Vigor 2860ac router, and a Draytek AP900 extender. The AP900 is in the lounge with the HiFi stack, and the 2860 is upstairs in my office, along with the PR4100. The 2860 and AP900 are connected wirelessly.

Apart from the Pioneer N-50 not communicating properly, everything else through the AP900 does just fine. An Android TV and an Xbox are connected to the AP900 via ethernet cable, as well as a laptop that connects wirelessly, and they all connect to the internet without a problem. Also as mentioned previously, the N-50 is connecting to the network, and the wider internet through the AP900, as it is able to connect to and stream all internet radio stations without a problem - it is purely the media server function that doesn’t work, which is why everyone seems to be so stumped!

I spent an hour on Friday with the Draytek techs, as they were suggesting that the AP900 / 2860 both need to be set to “WDS” mode instead of being set as a universal repeater as it is presently to improve the situation. However, an hour later, and even their own techs couldn’t set up the AP900 correctly so that it would work in WDS mode, so what chance do us mere mortals have?!?

I took config backups of both the 2860 and the 900 before the changes, so these have both been restored and everything is back as it was for now. I still think some sort of configuration issue within the 2860/900 set-up is the source of the problem here…

Have you tried connecting the Pioneer directly to the 2860AC router that the My Cloud is connected to, as a way to rule out if the extender is possibly causing an issue?

As previously indicated in my prior post, as a troubleshooting step try running Windows Media Player or iTunes and enable the streaming media feature in either program to see if the Pioneer can see/access media streamed by Windows Media Player or by iTunes. That may help rule out if the My Cloud is the issue.

Also it appears the Draytek router and or the extender may have a feature/option under Wireless called “Isolate Member” and an advanced option “Isolate Members with IP”. May want to check to ensure that both are not enabled. Also not sure if the option “Isolate 2.4GHz and 5GHz bands” would cause an issue if enabled on that router/extender.

What is Isolate Member with IP?

Thank you dswv.

The N-50 works when connected directly to the router. Therefore, it is not a compatibility issue sadly.


Hello Bennor

Thank you again for your reply - I am very grateful for the lengths that you are going to to try and work this out!

1: Yes, the Pioneer works when connected directly to the router. Draytek had me do this on Friday.

2: I have tried the WMP and enabled streaming. The Pioneer still doesn’t find a ■■■■ thing!

3: I was quite excited about this initially, but sadly, whilst the screens on my router are different, “Isolate member” is now on the General Settings tab, in the SSID section, and is not enabled. There is nothing relating to Isolation on the advanced settings… :frowning: - it felt as though that would have explained everything!

Just to confirm. When you say the “Pioneer works when connected directly to the router”, does this mean the Pioneer N-50K can access the My Cloud’s media content (either by Twonky or Plex) when it is directly connected to the Draytek router?

If this is the case that the Pioneer works and can access the My Cloud media while connected to the Draytek Vigor 2860ac but not when connected to the Draytek AP900 extender; one has a couple of choices at that point. Find a way to connect the Pioneer to the 2860ac router and bypass the AP900 extender. Or move the My Cloud and connect it to the AP900 extender to see if that solves the problem. Or continue to troubleshoot the Pioneer issue when connected to the extender.

Further troubleshooting with the extender includes digging through the extender admin screen ( to see if there are any settings that could impact network traffic like the router using one IP address subnet range (ex: 192.168.0.x) and the extender using another (ex: 192.168.1.x). Transversing different IP address subnets can be problematic depending on the router/extender configuration. To this end, it appears (per the PDF link above) that there is an option in the extender admin screen to enable DHCP for the extender LAN. May want to check to see if it’s enabled. May want to check the extender admin screen WiFi settings to see if Isolate Member is enabled and if there is such an option for the LAN. One can (if they haven’t done so already) connect a computer to the extender to see if that computer can access Plex or Twonky DLNA media on the My Cloud that is connected to the main router.

Hello Bennor

Thanks once again for the effort - much appreciated. I’ve been looking through the devices at DHCP settings…

I’ve uploaded some pictures below, but I can see that there might be an issue relating to the DHCP settings on the PR4100. At the moment, IPv4 is set to static, and IPv6 is set to off. When I try to toggle them to DHCP on each respectively, they pop up new windows that require settings that are beyond my knowledge and expertise.

Also, I was looking through the AP900 settings as you suggest, and I can see that “DHCP Server Configuration” is presently set to “Disable server”. I am guessing that this needs to be enabled? Again, I’m not sure what other settings, and/or IP addresses also need to be input into the fields in the AP900, therefore, I am hoping that all of the screenshots contain all of the necessary info somewhere? As far as I can see, the DHCP is enabled and active on the 2860 router.

Thanks once again…

Do not enable the DHCP server on the AP900 extender. On the My Cloud if you are changing from Static IP to DHCP; select DHCP for the IPv4 setting, then select Obtain DNS server address automatically. Do not enable IPv6 (unless you know what it is and that you are using it on your local network). Reboot the My Cloud.

As previously suggested, if you haven’t tried already, try connecting a computer to the AP900 extender and see if it see’s the PR4100 Plex/Twonky media server on the local network. Under Windows 10 the media server should show up in Windows File Explorer. Example:



it appears someone else years ago had trouble with a similar Pioneer media streamer, a N-30 and an NAS device (may have been a My Cloud), see this thread:

If you haven’t done so already you may want to dig through the following lengthy thread to see if there are any suggestions:

Hello again Bennor

Thanks - have now done this (as well as updating the firmware on the Pioneer). I think we have our winner.

When a laptop is connected to the AP900 via an ethernet cable, the only other device that it sees on the network, is the Android TV, which is also connected via an ethernet cable to the AP900 extender. That same laptop has full internet access through the AP900 though - so much like I’m experiencing with the Pioneer really.

My laptop, which is connected wirelessly to the router, sees a whole lot more (screenshot below), including both the Plex and TWONKY servers. This would explain why the Pioneer works when it is connected to the router, and not when connected to the AP900!

Therefore, do you know what I need to change for all of the discoverable items that are visible and connected to the router, to become visible to devices connected to the AP900? As I suspected, it’s some configuration gremlins somewhere within the 2860 router and the AP900 extender that are causing the blockage.