PR4100 don't automatically reboot after FW upgrade - Stuck and unreachable

Hello

I’ve had my PR4100 “Enable Auto Update” setting to true, thinking that this was the best way to ensure that I always had the latest possible FW installed on my NAS. But since I bought it (feb -19), I’ve always experienced that the NAS gets stuck on “Rebooting” after the actual upgrade, leaving the NAS more or less in a hung state. I cannot reach it, not by https and not through SSH. I know this isn’t a new problem, I’ve seen many threads about it - which makes it even worse I think.

The solution is to press and hold the power button on the front of the NAS to power it off forcefully, wait until disks and fans have all stopped and then press the power button again to power it up. This works, but It always feels like some kind of gamble, knowing that this cannot be really good for my system in the long run.

I am always hoping that “This issue is probably fixed in this FW release”, but so far - Nope! Still the same issue. I’ve now disabled the Auto Update option (in the ‘Settings’ -> ‘Firmware update’ settings menu) so that I can choose when to update the NAS FW “manually”, when I’m home and have the ability to toggle the power.

If someone else have had this issue, but found/heard about any fix for this, please share :slight_smile:

Best regards
Robert Nilsson

Hello mate,
you can search my posts from January 2018 and others I’m sure… same thing seems to happen to most. stuck on system rebooting… wait 10 mins and if no disk activity, punch it.
Scares the hell out of me each time, but I’ve done it so many times now, it’s almost standard operating procedure.
Not sure if they are ever going to fix it.
Lew66.

He Lew and thank you for your input. You might be right, but I have created a support case about this anyway. They should not just ignore this I think. If so many people have this issue. I will be this amazingly stubborn customer and update any progress here along the road :slight_smile:

// Robert

I’m having the same issue, Firmware version:2.31.174, it was automatically updated 3 days ago, everything was fine until just now, the connection was lost, rebooted a few times and still not able to access to the dashboard, I had it set to a static ip address after 150, when rebooted, i can see PR-4100’s IP connected and after a few minutes, it disappeared, the blue light is still flashing, and it saids “Welcome to WD”, how ironic…now the IP is even visible.

I bought this for a month and if this happened two days ago, I could still return it, but this happened right after the deadline, this product is just too unreliable after using it for a month, I’m on 40TB and now back to the stone age days using the external HD. Too much time has been spent on trouble-shooting and this has just become a serious issue to my workflow, I guess it’s time to go back to QNAP or Synology.

Hi lew66,

thank you for your suggestion, I read your post, unfortunately, it didn’t work for me, clearly there’s an issue with the FW updates and hopefully WD can address it asap.

Hi hisashi1314,
It seems like your issue might be a little different to what we have experienced. You say you rebooted several times and see the welcome to WD… screen.
With me, I don’t even get that far. It hangs during the reboot and all the screen says is rebooting. It will stay like that forever which is why we are saying to hold the power button in and force a shut down if there is no disk activity.
Yours seems like a connectivity issue if you see the IP address and then it drops off.
I’m sorry I have had that happen so I can’t really give you any advice.
I suggest you post exactly what you did and what happened. There may be some smart cookies that could help you diagnose the issue.
Good luck.
Lew66

Hi Lew66,

sorry, it was a typo, I meant the IP was “invisible” after I reset it, I tried the 40 sec reset and still no luck…

Update:

I opened up a ticket about this, after a few days I got an email where they asked for some more info; how the NAS was connected to my network and how it was powered stuff like that. I answered in an email and attached the system report that I couldn’t upload through the ticket for some reason.

Yesterday, I was called by WD Support. They needed some further info - or clarifications really to my answers in the email. After that, he said that he would escalate this to the correct group of people working with this stuff.

I hope that they actually find something out regarding this…

Meanwhile, since there are many people out there with the same problem. Could you share what you have experienced during powering off or rebooting the PR4100? I have always had this issue with every FW upgrade, but I’ve only done it 2 or 3 times I think since it quite new. At one or maybe two occasions I tried to power it off from the BUI [Hibernate] and I believe that I got the same problem then. My question to you guys; how do you experience this? Is it only during FW upgrade you’ve seen this or is it also a problem when rebooting or power it off?

I think that it’s an issue with the “shutting down” process. I’ve got a few things running on the NAS, Plex Mediaserver, SqueezeServer for example and I also use some of the more in-the-box services like WebDAV, sshd. So my idea is that maybe it got some issues with one of the running services. I’m thinking it tries to stop all the services, but what if there’s this one service that refuses to go down - wouldn’t that be experienced like this?

// Robert

I had the same issue. The system hangs because a program is not shutting down properly. The program that I found to be hanging on my PR4100 was the Plex Media Server software. If you go into the dashboard and under apps turn the Plex Media Server off, then reboot or shutdown and it works then that is the same issue you are having too.

Hi xete02

Thats good info. I will try that the next time I want to do this. In regards of firmware updates, I’ve disabled the automatic update functionality on the NAS and plan to do this manually when I’m home if things messes with me again :wink:

// Robert

Imagine you could create a company that sells products and software, but where the products and services you sell don’t have to work well and where you don’t have to provide any degree of customer service to the people who buy your products. Perhaps one of your creations would be a NAS that hangs after EVERY firmware update for EVERY customer.

2 Likes

Hello again… I did just that the other day when I updated my PR4100 to the newest firmware. I shut down Plex Mediaserver (and also SqueezeCenter) before trying to update. It worked. I think it’s quite bad that the update process just doesn’t shut down any non-system services before the actual update process kicks in. How hard could that be to accomplish? That, and to add the possibility to run a tftp server on the NAS is now highest on my wish list.

// Robert

Do you run any of the apps that I do three-m? Like Plex for example? Then I would suggest you disable the automatic update function and do this manually. It’s ■■■■, Iknow but it have been working for me at least. I really hope they fix this issue. It’s very annoying!

Add me to the list of " happy customers" with a bricked PR4100 after the 2.31.195 update.
I learned long ago to disable automatic updates because I got tired of waking up to find out it had updated and was offline since.
This time I manually installed it via web portal and it didn’t hang, it’s just a brick although the LCD says that everything is fine. I emailed WD support, but history tells me that I won’t get a response for a few weeks. I needed an excuse to buy a new Dell server to replace the NAS anyways.

Download the firmware and do a manual forced update from usb i can’t remember how one of the techs walked me through it when i was having problems with losing access if i changed the name on the nas. The fix was to do a factory reset…which is a bad idea on a back up device…but it did bring it back. The 2.31.195 update worked for me without a problem and the restart didn’t hang. Plex server is running.

I already downloaded and tried manually flashing FW after the normal rebooting it didn’t bring it back online. Display shows success and that it is online, but it is not. I even tried moving it to a different LAN switch.

Well if wd gets back with you they will have you do a factory reset i can put money on it! I think you can pull the drives and do a factory reset with out wiping then. When ever mine did this a factory reset was the only thing that would bring it back no matter what we tried. It was the same as you says every thing is good and running but i couldn’t connect to it.

Just experienced the same issue with my 4100. I tried resetting the NAS a hundred time (definition of insanity, I know!)

Finally called and spoke with a “helpful” tech person at WD. They are shipping me a new 4100 and I will have to ship the old equipment back. I will NOT be doing any firmware updates in the future.

Question, I pulled my hard drives out and numbered them. When I get the replacement NAS, of the same model, can I just put my drives back in? Will everything work?

1 Like

I believe they should you may have to go in to the dashboard and have it rebuild the volume. It should work as before as long as they didn’t get wiped while resetting and or reflashing the nas at least with my experience.

A rebuild does not wipe everything out?