Power LED not turning blue on device

I have a connection problem on my WD MyCloud device. It is connected to my internet router. It has been working ok for almost 3 years. There were a few connection problems throughout the years but it usually gets resolved by just restarting the WD device.

This time around, the power LED just doesn’t turn blue from white/yellow anymore, hence the device doesn’t get connected.

I have tried restarting both the WD device and my routers several times but it still doesn’t work.

Any advise/help would be much appreciated

3 yr?

Is this a 3TB model? The 3TB drives were (and still are) not very reliable, and fail quickly (with seagate drives being the absolute worst.)

It is entirely possible that your MyCloud’s drive has failed, and is out of warranty. If that is the case, then check out the “restore HDD” threads here. You can rebuild the MyCloud using pretty much any sata interface hard drive, but replacement with another WD-Red series is advised.

Thanks. Sorry, but could you help direct me to “restore HDD” threads, pls? I am very new to this forum.

Also, assuming that the device has failed, is there any way to retrieve all the files saved in it?

Try some troubleshooting steps first. Try using a different Ethernet cable. Try using a different network port on the router. Try connecting the My Cloud direct to a computer’s networking port. Try performing a 40 second reset (see this link).

If you are using AT&T Uverse or have one of the routers listed in the following WD Support document there are known issues that can cause behavior like that which you are experiencing. Putting a switch between the My Cloud and the router generally will fix that specific issue.