Poll ! Who has reverted to V3 firmware and why?


I have tried V4 Firmwares many times and have always needed to revert to V3 due to problems including (but not limited to)

USB problems inc corrupting partition tables

Network connectivity problems

Media serving and indexing problems.

Dashboard problems

Unresponsive MYCloud

Safepoint problems


I must say that V3 does everything I would hope for except for the shellshock vulnerability.

I can even create and update safepoint backups on one of my USB3.0 drives (connected Via USB 3.0 hub)

although I probably would not be able to restore from them and would need to do it manually (probably to another manufacturer’s equipment if the MYCloud bricks)

So please post here if you are on V3 Firmwares and lets have a count up

I reverted back after finding out sabnzbd, sickbeard and transmission didn’t work.

I know you can get transmission now but I have no problems at all with v3 and don’t care about the shell shock vunability

Went back to V3 because it gives me 60MB/s R/W speeds, whereas 4 sucked.

The shellshock bug has allready been fixed in the latest bash version. See my post for an update tutorial  here. Read the whole post first because there might be a newer version at the moment

1 Like

Many Thanks joskevermeulen

not being familiar with linux and knowing that WD have now addressed the shellshock vulnerability I opted for the simple 2 line route i.e

apt-get update
apt-get install --only-upgrade bash

before this I used some testing scripts from  "TidBITS which returned as Vulnerable

running them after the update all seems secure

Update running more test found elsewhere  found a vulnerability so resorted to the full tutorial! now on version 4.3-11+b1_armhf  all seems ok now:smiley:


reverted to v3 cause i wanted to use tahoe-lafs

Upgraded to V4 and haven’t had any problems (so far) but then I have not installed any extras on it which it was not developed to run.

Hi Daveyk15

I have not installed any “extras”

perhaps I should not expect to be able to use the USB port that was included in the “development”

I can run my USB drives perfectly with V3 firmware for months on end but every time I have upgraded to V4 it has caused problems which seems to be attributable to USB and the WD MyCloud becomes about as much use as a chocolate fireguard,

I have even been through the motions with WD support who could not solve the problem 

Several other people are posting in the forum with USB problems probably all on V4 firmware

Could be compatibility issues with some drives when WD introduced 64k page size on v4 kernel. So far I have no issues with v4 using passport 2tb usb3. Hopefully it stays good. And currently I’m running swap partition 24/7 on an expandable sony 32gb usb3 flash drive.

I have 2-My Clouds running the latest firmware, both seem to boot slower. Safepoints work … Sleep works … Cloud Access works … etc. I have no mods installed, but sometimes after a manual firmware update I have to perform a “System Restore” to bring back functionality. But for now, all is working and hopefully it will stay that way.

** Edited **

I have just noticed a degradation in read/write speeds as compared to v3.x, hopefully this will get fixed on a new firmware. I am only getting 60% of the speed I had before. :cry:

I went back just to get MyCloud stable and useful.

Couldn’t connect, play videos etc.


Like to add I do not have an external USB device connected myself so was unaware that there seems to be a problem.   Appologies to all the the folks having USB issues hope WD are aware of it and fix it soon for you.

As I posted elsewhere this 2TB MyCloud is horrible.  After upgrading to v4 I have been down for weeks.  I’ve had to restore numerous times with a paperclip just to get to a file.  I had a 2TB MyBook or whatever you call a usb drive on the MyCloud and could not access it at all.

I’ve disconnected the MyBook and connected it to a USB port on my computer

So, I am currently copying all of my data from both the MyCloud and MyBook to my other 3 NAS drives.  That should be done shortly.

After that I am deleting all data from both drives.

I reverted the MyCloud back to v3, but it still doesn’t work with the MyBook usb attached, so I am going to do a FULL RESTORE on the MyCloud and reformat the MyBook

The MyBook is going to get attached to my POGOPLUG where it will live happily ever after - I hope

We will see what happens to MyCloud after the full restore/

Pieces of **bleep** and total waste of time.  Never again.  I bought these things dirt cheap at Best Buy otherwise I’d be REALLY mad.

I’m staying with v3 mostly because of bittorrent sync.

I have not yet but might try it.  I can’t get safepoint to work with v4.

How do I roll back?


I have rolled back to version 030401-230 using these instructions:


Safepoint now seems to be working on manual and auto which it would rarely do in V4.  The dashboard also responds much quicker than it did with V4.  I don’t know about the read/write speeds as I have never prformed any tests. I can say the safepoint of 800GB to an attached MyBook took just as long with V3 (20 hrs) as it did with V4.


The link below is the method I use however a couple of time this has resulted in a blank dashboard which is usually fixed by the 40 second reset


same here…​2s so slow it is totally unusable.

reverted using  http://community.wd.com/t5/WD-My-Cloud/Easy-method-to-downgrade-to-previous-version-of-the-firmware/m-p/773073/highlight/true#M18956

I myself have been on V3.04 since having a harrowing experience in upgrading to V3.04 in which it frozed after updating. It was the first time I did a 40 second reset on my device with it going into a white light mode with no SSH ability because the device was busy initiating. The device took 3 hours to initiate and at the end I was glad it was back and I’ve only rebooted the device twice for fear that the device will remained locked in a white light mode.

I know I could SSH into it in previous versions while white light because I had to with the USB attached; I had to kill off two jobs in order to fix the USB attached problem. However some “know it all” user here on the forum told me that I could not have SSHed into any of the device while white light in all versions and in fact he also informs us that all versions after was just perfectly stable and he has no problems with V4 himself and therefore nobody else should have any problems and it would be a user error.

I have checked and I’m fairly sure that in /etc/init.d/bootmisc.sh the whole routine for DELAYLOGIN did not exist before verision 3.04. I am sure that particular user will check and will prove me wrong. 

Anyways, after restoring my setup, I vow that unless they fix sleep and the plethora of problems that seems to come with V4, I would not upgrade and this is looking to be more and more that I would be stuck at V3. 

However there is a good possibility that I will never upgrade for the following reasons:

  1. unable to upgrade from 3.04 to versions 5 due to needing to incrementally upgrade through all previous versions.

  2. white lighting and lock ups

  3. reseting all my shares and setups

I am afraid that one day the cloud.app for my iphone/ipad will be upgraded to be incompatible with my Cloud that is stuck at V3.04. When that day happens, I will be moving on to another product. 

Alright, now that I had my say, I can go for breakfast :stuck_out_tongue:

Reverted only yesterday by following this:


and then after hours spent due lack of responsiveness of the GUI, delays & errors (had to involve this command at some stage so you have some ideas how desperate I was):


eventually found and followed this procedure:


which simply worked as a dream.

Device now works exactly as expected and as I remember it, throughput is there, GUI reacts immediately, no network timeouts / freezes.

Support was talking to me already, I will keep ypou posted in separate threads.

I tried because of the usb problem. It worked before with 2tb image. Did it the same way as before (it worked fine this time). After a UI problem I decided I’d just restore the image and make sure to turn off automatic firmware updates. For some unkown reason using the 2tb or 3tb images all I get is the white light that blinks mabye once every 30 or 40 seconds.

I left it running for very long time hoping it was just doing checkdisk, but never got the blue light. I’m so pissed at WD at putting out firmware that breaks more than it fixes. I may just end up buying a diskless nas (Quite possiblely from another vendor) and using the drive out of MyCloud as the drive is still good.

Looked at the WD EX2 for extra protection before, but I’m a little WD gun shy at the moment.

Anybody have any ideas about the freakin’ white light with no cloud access?