Plex Setup on Fritz!Box 7590

Dear all,

I literally start to cry.
I got my NAS with 4 bays of 2 TB in a RAID 5 (works fine for me)
after that I wanted to start a media Server with Plex (I already payed the yearly duty)

Now Plex is always telling me that he can’t connect grand me the connection from outside my network and I have to give him a static IP Address. I’m searching and searching but I can’t find anything how to configure the Fritz!Box 7590

does anyone has any Clou how to get rid of this Network issue?
Followed several tutorials but no one seems to work with Fritz!Box (I don’t know if Fritz!Box is only known in Germany).

On the Fritz!box you need to set up a port forward.

Go to Internet > permit access > port sharing and create a new one (add device for sharing). Under device select the device running Plex and then at the bottom select new sharing.

There select port sharing and fill in the following:

Application: Other Application
Protocol: TCP
Port to device: 32400 to 32400
Port requested externally (IPv4): 32400

and tick the enable sharing and then OK and OK again until you get back to the top level and have saved everything.

That will route Plex through your Fritzbox to the NAS, and TCP port 32400 the one used by Plex.

You can if you want use a different external port, but if you do then you also need to tick the manual option in your screenshot above (Offentilchen Port manuell definieren) and put the alternative value there. That is useful if you want to run multiple servers on different devices on your network, as you can route them through different ports. The port to device has to be 32400 to 32400 though, it’s only the external one (the lower line) that can be changed.

Yes, Fritzbox’s are most common in Germany, but I also have a 7590 (in the UK).

And just in case, to do the static IP address you need to go to Home Network > Network > Network Connections on the FritzBox. Then scroll down until you find the listing for the NAS (or whatever you want to give a static address to). Then click the edit icon (the pencil on the right of the screen aligned to the NAS entry).

On that screen you can set the static IP address. Click the change button beside the current IP address and you should get the option to enter a new value (or you can keep the current one). The tick the box beside “Always assign this network device the same IPv4 address” (or the German equivalent presumably) should then become ticked, and when you click OK at the bottom it should assign that address as a fixed one.

Make sure that you don’t try and give the same address as something else has already been given on your network, although the Fritz should tell you when you try and click OK if there’s a clash.

I figured it out already.

How stupid can I be facepalm
Configured the port on the FRITZ!Box and everything was and is fine.

Blame on me for this situation. I was blind because of the settings from Plex that I forgot the general settings.

:+1: :smiley: