Plex server issues

Hello everyone! I’m hoping you guys can help me with this issue. I have purchased My Cloud Home so I can use it as a Plex server. Software is 9.5.0-186. I can use the NAS for storage and backup on my Windows devices in my LAN. No problems there. But I don’t need the storage option. I have been trying to get this going for so long, I’m no longer able to return this product to the store for a refund.

I have enabled the Plex server and when I tap on CONFIGURE, a webpage opens up and after I logged in with my Plex account, I keep getting this message is unable to connect to “My Cloud Home” securely

After checking Plex Help it keeps saying to make sure I have the latest version. I do not. It even provided step by step instructions on how to update via My Cloud dashboard. I’m simply not seeing those options in my dashboard. I’ve tried every option but nothing pops up with an option to upload the .bin file. What am I missing here? I’m honestly not even sure if this will fix my issue, but it is the first step in troubleshooting. Any help is appreciated!


Have you already looked at this?
My Cloud Home: Enable and Configure Plex Media Server (

Yes, I have. I have tried many times by disabling the server and starting all over. I cleared the browser cache, app storage, logged out, logged back in but it always shows the same message about not being able to connect securely. Thank you for your reply.

It appears nobody likes to support Plex, not even Plex community support on the Plex dot TV forum as nobody tried to answer these simple questions.

The answer is that is that if you are unable to disable Plex and delete the Plex folder and restart, re-enable and connect, then you may have to do a factory reset (back up your data before you do this).

Plex is ultimately a third party product. Western Digital doesn’t develop or update it except by making it available. WD is pretty clear about supporting third party products in that the support is quite limited.

So you are mostly on your own with trial and error when trying to make Plex work on the MCH.

I appreciate your reply. I tried the factory reset, the unit definitely rebooted but, to my surprise, when I logged back in the Plex server was still enabled for some reason (with the same error). I’ll try again I guess. I have no content on it so it’s not a big deal for me.

So I’m assuming there is no way to manually update the Plex server on My Cloud? Thanks again.

Apparently the reset button doesn’t reset the unit. I kept it pushed down for a full minute. The unit reboots but it doesn’t reset anything. So I had to do it remotely via WD Cloud website, with Erase all data. It did but after enabling the Plex server, the error remains. Man I wish I knew this was such a headache…

This subforum is not a good place to do Plex support, that is why my handle is NoPlex. Plex is third party software that is hardly supported by the software provider, Plex itself and Plex should try to support it on its forum as linked above, but Plex apparently doesn’t if you just look at their lack of response.

You have not fully completed the MCH factory reset. I am pretty sure if you try Factory Reset a couple of ten times, it will reset and no longer be identified with your WD account. Either that or there are file system or hardware errors that is preventing the MCH from being reset.

This is what the other MCH Plex heavy user said:

The MCH may still has your identity associated with your MCH after the webapp user erasure but some Plex configuration files remained on disk which is where is Plex error is coming from.

Pin Reset and System Erase a My Cloud Home Guided Assist

  1. Monitor the LED status when power is applied to the drive.
    The My Cloud Home LED will go through a series of blinking stages to 100% illuminated (solid white) indicating a ready state.

If the My Cloud Home LED becomes solid white immediately after applying power and never blinks:

  • may not have completed the boot up sequence properly.
  • the drive may have file system, media errors or data corruption.
  • the drive has failed.

Select the best option that describes the LED Status when power is applied to the drive.

Usually the soft rest is not good enough. Did you receive the email from WD that a recent reset has been made?
If you didn’t, then the reset is not done, which explained why plex is still enabled.

If you received the email, then you should not be logged to your device using the same credentials.

I have reset it twice and both times I got the email. As far as credentials go, I only have one Plex account and one WD Cloud account.

You are better off with a new Plex credential and use the browser incognito mode.

Plex know they have a problem with trying to reclaim a Plex Media server and one of the support person wrote a utility to reset and reclaim PMS, but it doesn’t run on the My Cloud Home.

In a supported platform such as Linux, this is how Plex community support would deal with this. Notice even under the best circumstances with the tool, it could still be stymied by a network problem and there was no resolution to the case.

How do I transfer my Plex Pass? Is there a way? Thank you

Success! You guys are absolutely right about something being left behind after a reset. So I created another Plex account and set everything back up. It worked just fine.

Since I had lifetime pass for my other account, I de-authorized all devices and
removed sessions then deleted my new Plex account, then went back and reset the NAS again, enabled the Plex server and logged in again with my original Plex account and everything worked right away. Thank you all for your help!

I spoke to soon. The error came back. I give up. Thanks for your help again

Yes, well. There is a good reason nobody really wants to support Plex on the MCH - it is too hard to fix when something goes wrong in a closed OS. I would just get something like the HP 800 G2 or slightly better (G3 or G4) with a Intel processor to do transcoding if needed:

Don’t know if you ever managed to fix this but I’ve just managed to sort it.

Basically I had to navigate to the local instance of Plex server on port 32400 on my cloud home using its private IP address e.g.

When I navigated to that I could see that it hadn’t reinitialised properly so logged in then ran through set-up (had to reregister my libraries unfortunately)

That then sorted the security issue and the device properly registered for the app etc.

Hope that helps

1 Like

If anyone could reset and reclaim their My Cloud Home Plex Media Server that had that showed “unable to connect securely” then that would be great, but that is usually unlikely.

This problem originated with what happened in August of 2022

Plex Media Server User Credential Reset Utility In light of the security event plaguing everyone, a ‘quick & dirty’ tool was crafted. It’s a little rough around the edges but gets the job done. It’s been evolving due to the need. This tool, Removes the existing Username, Mail, Token, and PlexHome preference values from an existing Preferences.xml file leaving the server now suitable for claiming. Reclaims the server via a user-entered “Plex Claim Token” (obtained by visiting …

Unfortunately, the My Cloud Home cannot utilize such a tool because of the lack of user accessible SSH and/or schedule tasks, so the My Cloud Home is not supported. The alternative is to do a full system reset on the My Cloud Home.
Currently supported platforms (more can be added)

    Linux (workstation & server)
    Synology (DSM 6 and DSM 7)
    QNAP (QTS and QuTS)
    Netgear ReadyNAS
    Western Digital ( OS 5 – PR,DL, and Ultra - at this point
    (recommend using Public shared folder)
    Selected Docker containers
    Manual Path specification (which includes containers and custom) (See below)

1 Like

You can fix it by clearing the cache and ensure that your Plex app was updated to the latest version. Also, make sure your network settings are correctly configured. This resolved the streaming interruptions for me.
Hope this helps.

This Plex server issue was about: is unable to connect to “My Cloud Home” securely

This answer seem to have come from a bot or a gen-AI (which should all be called d-gen for degenerative answers).

No, clearing the cache and/or an updated Plex won’t fix an authentication reset and reclaim of a Plex Media Server issue.

In addition, the new PMS 1.40.x and higher use a new database that is prone to detecting corrupted metadata such as giving “database disk image is malformed” errors which may be the reason why so many updated Plex MS caused so many crashes. There is currently no way to fix a PMS crash in the My Cloud Home other than a total OS4 wipe and reset of user data.

Feb 17, 2024 10:04:05.888 [10736] INFO - Running forward migration 202309200919.
Feb 17, 2024 10:04:05.949 [10736] ERROR - SQLITE3:0x7ff781175760, 11, database corruption at line 91363 of [a29f994989]
Feb 17, 2024 10:04:05.949 [10736] ERROR - SQLITE3:0x7ff781175760, 11, statement aborts at 3: [SELECT id, extra_data FROM tags WHERE extra_data IS NOT NULL] database disk image is malformed