PC cannot detect my 2TB WD My Book USB 3.0

PC cannot detect my 2TB WD My Book USB 3.0

Hey guys,

My Asus notebook which is currently running Windows 8.1 cannot detect my HD. 

I have had it for a few months now, and it has been working fine. 

Recently I had my laptop repaired after a drop and the internal harddrive had to be replaced and Windows along with all drivers re-installed. 

I was given my laptop back last week and I later plugged the HD in and everything was working fine, although, now after a few days of not using it I have noticed my laptop is no longer detecting it (through My Computer). 

When i plug it into the USB 3.0 Port, the white LED on the HD begins flashing and i can hear it reading (It doesn’t make any unusal clicking noises or anything suggesting that it could be damaged. And to my knowledge hasn’t been dropped or mistreated) but nothing comes up.

When I go to Device Manager, under Disk Drives it shows ‘WD My Book 1140 USB Device’ when it’s plugged in and in properties for that, the Device status is ‘This device is working properly.’ 

When i go to Disk Management, it comes up with a message box labelled ‘Initialise Disk’ stating ‘You must initialise a disk before Logical Disk Manager can access it’ it gives me ‘MBR or GPT’ as the options for partition styles with GPT already ticked. But when i proceed, a message box comes up with a red X stating 'The specified disk is not convertible because the size is less than the minimum size required for GPT disks. Then closing that, it shows ‘Disk 1, Unknown and Not Initialised.’ 

Here is a list of things I have tried to resolve this:

I have tried plugging the HD into my MacBook as well as another PC both with no results.

I have plugged the HD into other USB ports on my laptop.

I have plugged a USB stick into my laptop to see if it would show and it did. 

I have gone though Device Manager and attempted to Update the driver for it, with it saying it’s up to date.  

I have gone to Device and Printers through Control Panel and tried troubleshooting the HD only for it to say ‘Troubleshooting couldn’t identify the problem.’ 

I have downloaded the ‘WDFirmwareUpdater’ from their site and attemped to install that, only for it to come up with a message stating that i need to close all open applications and then run the firmware updater again. (I had no other applications open or Spyware/Anti-virus apps opened). 

I have downloaded and installed the ‘WDSmartWare Installer’ but when it says to select Backup Source and Target, the image of the HD ‘My Book’ has a yellow pencil with a red X next to it without allowing me to select it. 

I have downloaded ‘WD Quick Formatter’ only to have it come up with a Runtime Error stating, 'This application has requested the Runtime to terminate it in an unusal way." 

I’m now out of ideas with what to do and considering just giving up and accept it is somehow now defective. 

But if anybody else has any idea i’d love to hear it!
Thanks! :slight_smile:

Let me know what you find out as my WD MYBOOK Essentials doesnt  show up any more either on either of my computers.  this is the third consecutive WD drive that has crashed like this.  i  only owned this one 12 mos and it has never been moved from its perch by my computer.

I am losing my faith in Western Digital.

My problem’s much the same.  Mac OSX updated in August and since then I cannot get my Mac to recognize my My Book.  Recognition and access has always been a hassle with what WD (laughingly?) calls SmartWare, but now it’s simply impossible.  I doubt that the recommended FirmWare updater is going to find my drive (and if it does, its warnings suggest that it might well erase or damage what’s on the My Book before I can copy any of it to another drive).  Fortunately I’m a historian, so the data on the drive is unlikely to become obsolete, not for a couple of years, anyway.  However, I’d prefer not to wait that long.  

I see thoughtlessness out there in WD-land.  I hope you will fix this problem before your company becomes known for not caring about follow-up.  

It’s like we are all expiriencing the same problem i have two 1TB’S that just crushed out of the blue .i don’t know if i will ever buy a WD product.

Hi guys, note that when a computer does not recognize an external drive it can be caused for several reasons. Try following the steps on the links below. 

How to test a drive for problems using Data Lifeguard Diagnostics for Windows 

WD external drive is not assigned a drive letter by Windows or Mac OSX and data on the drive is inaccessible

How to test a drive for defects or problems on a Mac 

Okay guys, so it seems I may have found the solution…

Make sure to read all of this prior to actually begining the step-by-step instructions to decide whether it is the correct solution for you and your situation. 

Step 1: Open a window closest to your current seating arrangement.

              Purpose: to allow some cool breeze to keep you calm.

Step 2: Spend hours, if not days, reading through forums and searching through every last page on Google to find a                     solution to resolve your failing WD. 

Step 3: Realise that you’ve just wasted your time and money purchasing this product and begin to gain a temper.

Step 4: In the heat of the moment after becoming quite pissed off, aggressively yank the power and USB cable from                     the back of your External HD at the same time. Note: Be sure to do some damage to the cables. 

Step 5: Grab a firm grip around your HD and stomp your way over to that open window. 

Step 6: Launch that defective pile of metals and plastics as hard as you can onto a solid object. i.e. road, brickwall,                       your neighbours house, or even your neighbour. 

Step 7: Continue to watch as it is broken into 101 and pieces. 

Step 7: Bask the sh*t out of that small sense of victory and go grab yourself a beer. You’ve earnt it.

Having been through this myself and like you very frustrated I believe I have found a solution to this problem and I wish WD would correct this problem.

I found that if you format the USB drive or thumb drive with a XP computer (NTFS) this will allow the WDTV to detect the drive properlly

I tried this with a number of drives from a small thumb drive to a 3T WD drive.

If the drive is formated - NTFS with a Win 7 or Win 8 the WDTV will not detect the drive.

The formating of the 3T drive on a XP machine took about 5 hours.

Good luck

This is about PC, not Apple, Windows, not iOS?