Brand new WD 3TB My Book suddenly not recognized

so, I bought this 3TB mybook yesterday and up until today morning it worked fine! i transfered some files to it, all fine and well … but today suddenly … blackout. i mean, drive isn’t recognized in My Computer, no matter what I do. it’s recognized in device manager though and it says it should work fine.

I have no idea what to do … oh, when I go to “safely remove hard drive”, it shows “safely remove usb mass storage device” but no drive letter attached, even if just yesterday it still worked fine …

I had this problem when i first got mine, they sent me a replacement. same thing with the replacement… then somehow i figured it out, It had something to do with just deleting all the drivers and reinstalling them it took me days the first time just reinstalling and uninstalling drivers. After that mine worked fine for the past 5 months and all of a sudden a few days ago it went out and is doing the same thing again and I have tried everything to get it to work, and am really getting agrivated.

If you find anything out please keep me posted, I will be sure to do the same.

oh, I’ll make sure to try this out!!!

I got completely devastated at the thought of losing my data … the story is, i have/had 500 GB mybook, the version from 6 years ago and it slowly stopped working, so i bought new hdd and transfered data to it … so yep, I sincerely hope it’s not the failed drive or anything … i’ll reinstall the drivers also and i’ll let you know, how it worked, asap!

it’s frustrating, since I have also 2 other external hdd’s from wd (this old one 500 GB, other 1,5 TB) … and they have never even once dissapointed me. *touchwood*

but you know, my theory — if it’s recognized in device manager and shown as “working fine” … i can manage to get it work eventually.

gah, somehow it doesn’t help … another problem detected (maybe it was there before already, i just failed to recognize it …)

it can’t spin up fully. no clicking noise or anything, just constantly trying to re-spin … and as i said, it’s being recognized, when i attach it, shown in device manager, but not in windows explorer or disk management. :frowning:

Mine is only showing in device manager also, and the light on the drive is continually blinking the drive itself is making no noise. It tells me the drivers are fine and everything. i’ve tried it on multiple computers even and the same senario on all of them. I even took it a step further and took the drive out of the enclosure and connected it to the internal bay of my computer directly to the mother board, and it shows up the exact same just in device manager, and not in explorer or disk management…

I think it may be the drive bios or firmware, though i have tried to update the bios and it just gives me an error message saying that all the programs must be closed for it to work when there are no programs running.

Actually it is showing in disk management, it is showing up as Disk 6 Uknown Not initialized, and it won’t let me initialize it.


Have you found any solutions to this problem yet? I am having the same issues, and no matter what I do, it won’t recognize under My Computer. As you’ve said, it shows everything is fine in Device Manager, I have uninstalled and reinstalled all drivers and SES…no change, only flashing LED. Mine is the My Book Essentials that has a power cord and a separate USB cable.

I called tech support and the guy seems to think its the USB cord for some reason… I’m doubtful that is the problem but we’ll see. I also discovered that it doesn’t seem like it’s being assigned a “drive letter” in Device Manager. I tried to add one, but then it gives me an “I/O” error, or tells me that the drive needs to be formatted first, which can’t happen because…

I have all of my family photos from the last 10 years on this thing! The My Book worked perfectly fine out of the box, and out of nowhere I started having this problem. I HAVE to recover those photo files! It just makes no sense that it was working perfectly well one moment and not working at all the next, just in enough time to move my most important files onto it!

it’s me, cherry_tartlet, had to re-register, 'cause for some reason i couldn’t log in. -.-;;; weird …

anyway, no solution whatsoever … I tried it all. connecting the drive to different power outlets, different USB ports, even THREE DIFFERENT PC’s (mine, my dad’s and my laptop … which was up until some time ago the last resort I had with my oldest mybook … don’t know the reason, but a laptop has windows 7 on it (both pc’s are with xp) … and it recognized the old (slowly dying, as i see now) mybook almost instantly, while i struggled with it on both pc’s …)

so yep, even on laptop, it doesn’t work at all … i mean, it’s “recognized” as something being plugged into USB port, it won’t let me install the drivers (says it doesn’t find them), doesn’t assign the partition (previously it did) and I’m afraid, something’s gone horribly wrong. aaand it worked perfectly fine up to yesterday morning.

so, in short, if anyone finds a solution to this … what I see wrong with my disc.

  1. no matter what I do, it’s only recognized in device manager. not in disk management or my computer.

  2. it’s got no assigned drive letter, in “safely remove device” it’s only “safely remove mass usb device”

  3. when I plug it in, it’s ilke "spin up/click/spin-down, but i’m not sure about the click, maybe i’m misshearing things, but it’s definitely spin up/spin down and after several repetitions it doesn’t do it anymore, only the light in the front blinks, and it’s like the whole thing has stopped spinning. or maybe it spins and the whole thing is just so quiet that i can’t hear it? doubt it. I have other two wd external hdd’s and when i put hand on them, i can feel them both vibrate. here? after the usual spin up/spin down routine - nothing.

  4. i did it all, tried to plug it into different power sockets, to different usb’s, different ports, even tried to use the power adapter from 1,5 TB elements, no success.

  5. when i check it with Everest program, it shows there but has assigned storage space of 0 MB.

i’ve already kind of accepted the fate of not getting data back … didn’t have the backup, since i bought the new disc for the purpose of moving the data from disc that was slowly but surely dying … but i hope that the new disc is gonna work fine … it’s scary, once you experience disc failure for first time.

I have not found any solution… I’ve literally **bleep** near tried everything, i’ve basically put it off because it’s killing me knowing all of my data is possibly gone… but if i do come up with something i will be sure to post back. goodluck to the rest of you guys… next hdd i get i’m buying two different brands, and using them both for backup. probably wont ever buy a western digital again.

Cherry - The WD500GB disk runs way too hot, about 60-66C. When "normal" disks operate in the 35-50C range. Heat is what killed your drive. And WD themselves say this 500GB disk has a specific design life of 5 years. That’s it. No more.

It works well for a long time, then dies slowly. Perhaps slowly enough to dump all the data to a new disk. Several of mine had given up the ghost that way. So to speak.

External disks that have no cooling CANNOT be expected to last very long. Mfg expects you to throw them away at the end of their life.

Allow me to add - two drives by two mfg is a time honored method of backup. And go with 2.5" disks. They are better engineered out of necessity. You can’t cut corners in a 2.5" design like you can with a 3.5" formfactor.

One more thing. the 500GB disks are among the worst from which to recover, data recovery pro’s all tend to agree on that. A lot of moving metal in these and extra bolts to hold it all together.

If you need your data back, the best thing is to seek help from Ontrack or Drivesavers or any other major reputable operation. Then always backup your stuff, 2 copies at all times, no exceptions.

Sorry for all the postings, but I ma in the middle of conducting some scientific research.

If you really value your data you should seek a pro service that can operate on the disk and retrieve those photos. Playing around with it and trying all kinds tricks is just going to make things worse.