Computers do not recognize my WD My Book Essential

My WD My Book Essential was working completely fine until yesterday, which was the first time I hooked it up to my new computer (Dell laptop with Windows 8, if that’s relevant). 

When I first hooked it up to the new computer, the computer did recognize it and I was able to view the files within it for about a minute.  Then all of a suddent it disappeared and I got a message saying that my computer did not recognize the device. 

Ever since then, every time I have tried tp connect the hard drive to this computer either nothing happens, or I get a message saying that the computer does not recognize the device.  Even worse, the same thing is now happening when I connect it to my old computer, which previously had no problems with the hard drive.

I downloaded the WD SES driver as recommended, but this did nothing.

Can anybody provide any advice? 

Does the drive show in Disk Management? It sounds like a corruption issue. Maybe something like test disk will fix it.


Same thing happened to my husband.  But this case is he just replaced a new motherboard and processor. When he plug in the WD My Book Essential, we cannot see anything happening even the icon for WD SmarWare cannot be found in My Computer. What to do?

We found the solution … it doesn’t work to usb 3.0 but we’re able to view it at usb 2.0 

I have the same problem.

How did you change it back to USB2.

It shows up as a Device not an external hard drive.



@Joe - First, we plug My Book to usb 3.0 and its not working. We unplugged it and plug to usb 2.0 port 

Note: My Book Essential usb 3.0 + usb 2.0 <–100% compatible. It says Ultra fast Performance with usb 3.0. Yes, its an external hard drive but it will only shows either My Book or My Passport 

Joe: No it does not show up at all in Disk Management. 

So, practically speaking, what does a “corruption issue” mean for me? 

It is just a coincidence that it stopped working almost immediately after I connected it to my new computer?  Could there be something about Windows 8 (or something else with the computer) that is causing this.  There were no problems at all when I was using it with my old computer.

You know my 500GB drive just recently started doing something similar.  I connect it, and the blue activity light comes on on the front and it even shows up in Device Manager under Disk drives as WD.  It shows as a disk in Disk Management that needs initialized, but when I try to initialize it I get an incorrect function error.   Still trying different things but nothing has worked yet.  If something works I’ll shout.  If anybody else is familiar with this I would love to hear what you did to fix it.