USB Device not recognized

I have a WD “My Book Essential”.  It has always worked fine.  A couple of days ago, I suddenly got a message saying;

                            “USB Device not recognized.  One of the USB devices attached to this computer has malfunctioned and Windows does not recognize it”


  I am running Windows 7 on a hP desktop.


Does this mean my Book is no longer working, and I have lost all of my data on it? Thanks very much for any help.

It happened the same to me with My Book several months ago. 

I tried in different computers and it wasn’t recognized.

I’ve got a lot of files inside and I don’t know what to do.

Any help?


Thanks for private messaging me that once you reconnected it, it started working.


Plug it back in and check to see if it shows up in Disk Management.  If it does, then there is some corruption on the drive preventing it from showing the files.  If you don’t see it in disk management, and you have tried it in different computers, with a different usb cable, and maybe even a new power supply (you’d want to call tech support for that), then you will need to go to data recovery if you have to have your data back.