How to fix WD

A friend gave me a WD MyBook Essentials yesterday to fix. He has 465 gigs of video of his band and other bands as well, and 1,000 ish MP3songs. Lost forever unless I can fix it. I showed up here and read and read…

“There IS no solution, as the long list of desperate contributors to this thread will teach you. It is a malfunctioning product.” As one poster put it.

Then Thread after thread after thread…

" WD Hard Drive Totally Stopped Working"

" My Book 3TB External Drive stopped working"

" USB Device not recognized"

on and on and on and on…

This product is [Deleted - Trancer]. Stop buying. There is no reason it’s not working OTHER THAN it’s a bad product. Period. No more threads. STOP. It’s not your OS or upgrade device in device manager. Stop wasting your time. But you need to get stuff off it. 

A trick us techs know…

Freeze it.

I put in freezer for 4 hours. To be safe I then put in frig for an hour to heat up a little to not be fragile. It works. My friends device is now working, but this is a tempary fix. At least long enough to get data off. Buy a long USB extended cord and and stick it freezer or frig while it’s downloading. Then toss the device and never buy WD again. Ever. 

No this is no joke. I have a BS in electrical engineering and I run a small computer fix it shop out of my garage. Do it. Air tight zip lock bag. Stick it in there. End this 200 pages of madness. Download your stuff. Toss. 

While I’m glad you recovered the data I would strongly advise anyone against exposing any electrical device to water or moisture, but that’s me.


Then keep it in the zip lock bag with just enough opening for the cord. 

There are 193 pages and 30 threads per page that is 5790 threads of complaints. With 20 or more responses at least per thread for 115,800 attempts to correct the problem. These are writen complaints that WD is aware of. 

Stop buying this. 

hi sorry to bother like this but my wd external hardrive is not initialising at all. i can see it in the disk management but cant see it in my computer .i have tried tons of software to fix it but nothing .when i try to initialise it the disk management ask for mbr or gpt i select mbr cause its only for 1-2 tb but i get incorrect function message .i looked further and it says code 45 problem or something .

any help will be appreciated as i desperatly need my data off the drive

Ridiculous. Having to reinstall your OS, freeze it, buy a $100 of cables and software, stand on your head, bark at the moon. Shouldn’t have to do any of this in the first place.      

Does the freeze method really works?

I have watched someone tries it on youtube and it seems to be.

Does it works only for HDD which doesn’t power up and spin?

For my case, it does power up and spin but does not get detected at all.

I’m getting desperate for retrieving the data.

Freezing normaly works sometimes when the head is stuck to the platters

this time is not the case or the disk wouldnt spin at all and would bip

1 Like