OS5 has ruined MyCloud drive

I have been using MyCloud (3 TB) for backups and file storage, including 200+ dvds I have converted to MP4 format, so I can access them remotely whilst on holiday.

Upon upgrading to OS5, I can still access the drive through Finder on my Mac, I can still add / view / delete files through Finder or the web connection, I can access my movies via DNLA on my TV and play them etc. So no real change.

But….I can no longer access my files from the IOS app, on either my iPad or my iPhone once I have installed the MyCloud IOS app. Even when I am in the house and on my same network, I have no access. Obviously, when I am out and on a different network, I cannot access anything either.

If I ‘reset’ the drive at home (using a paper clip for 4 seconds), then the drive magically reappears for about an hour on my IOS devices. But all I get is ‘currently indexing’ (so no access again) and then, about an hour later, the same old ‘drive is offline’ message. So we’ll done WD, you have managed to completely ruin my NAS drive by releasing an app that doesn’t work. Bravo.

Would it be too much to ask you refund me for this (£149.00 I paid) as I cannot use it now, I cannot access my files when out and about (the whole reason I bought it!) and I cannot sell it as, frankly, you have effectively bricked the drive with your new software.

Will never buy anything from WD again….’

Have you installed the OS5 My Cloud app for iOS on your mobile device?


Obviously! That’s what I’m complaining about - the app will not let me access ANYTHING on my NASdrive! And because my drive has been updated to OS5, I can no longer use the OS3 app which worked perfectly, both whilst at home on the same network or whilst ‘out and about’ on a separate network. I have tried uninstalling the app, reinstalling, resetting the drive (both the quick and total reset options) and……nothing. The new OS simply doesn’t work and has made my NAS drive pointless.

Its obvious to you but you didn’t state in your original post or the edit you made to your original post that you installed the OS5 My Cloud app, so it isn’t obvious to others which is why the question was asked.

Troubleshooting steps. Check to ensure remote access/cloud access is enabled and connected in the My Cloud Dashboard. Sign out of the OS5 My Cloud app, then sign back in to the OS5 My Cloud app using your My Cloud OS5 cloud account.

The following WD Knowledge Base Article may have some additional information that may be relevant.

My Cloud OS 5: How to Add Users and Enable Cloud Access

Thank you for your assistance - I do appreciate it. Darn site more than any help from WD.

But you cannot access the NAS that has been upgraded to OS5 without downloading the OS5 app, hence my ‘Obviously’. I assure you I am computer / IOS literate, the problem is that my NAS (which has worked perfectly for 3 years) has been rendered useless by this upgrade. Reading other posts, I am not alone on losing access via the OS5 app.

I will try your suggestions - most I have already done - and see if there is any progress.

Access the My Cloud Dashboard using a web browser on a computer/device connected to the same local network as the My Cloud.

My Cloud OS 5: How to Set Up Using the AdminUI Dashboard

My Cloud OS 5: How to access the Dashboard