My Cloud app doesn't work any more unless you activate cloud account!

Before OS 5, I enjoyed the app access to all of my NAS 4100pro from anywhere by detecting the NAS device while in network and access them with a user name, after updating to OS 5, the app won’t connect or detect them unless you activate a cloud account, which is something I won’t do due to the high risk of hacking, ( I actually was hacked recently for ransom and my data on some shares that had FTP on and cloud account were emptied out except for a warning ransom text file, I disabled the cloud account immediately!).
so is there any solution to still use the mobile app without activating the cloud account? thank you for your help.

3 Likes

Plus one. I want see here answer from WD.

1 Like

I’m not an WD employee but I’m sure the the answer is “No”.

1 Like

The My Cloud OS 5 mobile and web app requires Internet connection to function with the My Cloud OS 5 NAS. Here is the feature difference between OS 3 and OS 5 for your information:


Thank you jchen,
by “internet connection” do you mean cloud access setup? because both mobile device and NAS are connected to internet already!
P.S from reading the feature differences snapshot, it seems that the OS5 is a downgrade except for the “new, up to date design” why would WD do this and ruin all of the nice work we had for many years?

1 Like

Such a poor job you guys have done rolling out OS5 a complete effing disaster. I won’t be using your products in the future.

1 Like