Accessing My Cloud via app on local network

Hi, I am trying to access my WD My Cloud OS3 NAS locally on my network from my android device by installing the My Cloud OS3 app. However, it will not log in and when trying to add the device manually it’s asking for a code. Is it not possible to use the app to even access the device over the local network anymore ? If so, how can I access it as my phone’s file manager does not support network shares. Thanks.

No it is not possible using the OS3 My Cloud mobile app. As WD has been warning people for months, WD terminated OS3 remote access using the My Cloud OS3 mobile app and web portal on Friday April 15th.

My Cloud OS3 End of Service

On April 15, 2022 , support ended for prior generations of My Cloud OS, including My Cloud OS 3. There are critical security updates that are only available for My Cloud OS 5-compatible devices. If your device isn’t compatible with My Cloud OS 5, you can only access it locally. As of April 15, 2022 , your device no longer receives remote access, security updates, or technical support. To help protect your content, we recommend that you immediately back up your device, disable remote access, disconnect it from the internet, and then protect it with a strong, unique password.

There are numerous free and paid file manager apps one can download from their mobile OS app store to access a local network OS3 My Cloud device. For example on Android, ES File Manager is one such popular (or used to be) file manager app. Many other apps are available for one to experiment and find which one works best for their needs. Plenty of “best” blog posts out there, for example:

Personally I’ve been using Asus File Manager on several Android devices to access an OS3 My Cloud. Its basic and works well for my needs.


1 Like

Alright thanks for the info. I was aware that remote access was terminated however I thought I would still be able to access the device locally using the app.

1 Like

Apparently the OS3 My Cloud app connects to WD’s OS3 servers (a wild guess is probably to verify a user has a account) even for local network access. Unless WD decides to fix or update the app we OS3 My Cloud affected users will have to use third party file manager apps like those previously mentioned.



I would highly doubt that WD has any intention to update the OS/3 app.

Honestly, the transition from the OS/3 to the OS/5 “system” has been underway and well publicized for about two years. All of the hardware that can run OS/5 was given and upgrade path. Those that couldn’t run OS/5 have been out of production for a few years.

I would not have expected them to update the app.

“Could” the app have been modified to work? I have no idea - - but I suspect internet access and WD server authentication was a core aspect of the functionality - - and I am not surprised that they have not devoted resources for app support for devices that are now “end of life”.

I don’t expect WD to fix the OS3 My Cloud app to allow local network access to My Cloud devices. But it would have been nice if they did (or do in the future) to help their customer base. It appears one may still be able to use the OS3 My Cloud app to access a My Passport Wireless, My Passport Wireless Pro and My Passport Wireless SSD. And the OS3 app indicates Dropbox, Google Drive and OneDrive are available cloud services. There is also a option in the OS3 app to manually add WD Device option where it asks for an Activation Code. Don’t see a way to get that “code” in the last firmware update for OS3 v4.x firmware’s My Cloud Dashboard.


I have HDD passport wireless pro and the older Passport Wireless.

To be honest. . . .the OS/3 app seemed not to work very well for those devices for quite some time.
The app just didn’t seem to “find” the devices consistently. Frankly. . .in the last three years; I don’t think I ever had the app able to access all my OS/3 devices at the same time. Finally, I just gave up on it.

None of these wireless have had a firmware update for several years; and I don’t think they are sold anymore. In others. . .silently transitioned to EOL.

I can so far confirm that WD Photos app (now long defunct but its android APK files can be found in various depositories on the Internet) does work over the local Internet without any problems.

My Cloud OS3 app has indeed stopped working, I am yet to check its older versions (also available, as per above).

I was also thinking that you can still use the OS3 app to access your decivce locally. One smartphone is still connected - the other suddenly removed the cloud device from the app. But we are not able to reconnect because of the missing activation code…

We use already a 3rd party app but it has no synchronize function with the local smartphone storage so that you can access some files also offline.

Edit: Has anyone heard of an app which can provide the “synchronize” function from the OS3 app?

Many if not most third party mobile file manager apps will let you “download” or copy a file from an NAS to the local storage of the mobile device or from the mobile device to the local network NAS. Do it all the time using the free Asus File Manager app for Android on several mobile devices to copy files from a OS3 My Cloud and other local NAS devices to/from my mobile devices.


Hello Bennor, thanks for your reply - what I search is an app that more or less automatically checks if a file on the cloud or phone has updated and then synchronize with the other device.

I want to save the time to navigate to the cloud file and then manually download to the phone.

I edited the post above because “download” was the name in OS3 but it was more synchonizing and we used it often.

I tried now 3 different apps but nothing is working very good for replacing the synchronize functionality.
The best results were with the free app SMBSync2 for Android.
Blog Entry from EKiwi: Android smartphone sync photos and videos to NAS SMB share
See also youtube video: Android smartphone sync photos and videos to NAS SMB share

But with this app you are only able to synchronize - it is not a file explorer. So you have to switch to a file explorer app after you synchronzied the files with your phones.

Has anyone found a better alternative for synchronizing with the phone?

I haven’t tried it but this app (FolderSync) claims to sync and be a file explorer. Says it supports SMB1 and SMB2 so it may be able to access a local network NAS like the My Cloud.

FolderSync enables simple sync to cloud based storage to and from local folders on the device SD cards. It support a wide range of different cloud providers and file protocols, and support for more platforms are added continuously. Root file access supported on rooted devices.

Effortlessly sync your files. Backup your music, pictures and other important files from the phone to your cloud storage or the other way around. It has never been easier. Automation support using Tasker and similar programs enables fine grained control of your syncs.

FolderSync contains a full file manager, that enables you to manage your files locally and in the cloud. Copy, move and delete your files in your cloud/remote accounts. Support for creation/deletion of buckets in Amazon S3. Upload and download files from the phone. It’s all supported.

Edit to add: Goodsync may be able to do what you seek as well.

Explorer allows you to Explore any remote computer running GoodSync Connect.
Explorer can copy (download / upload) files and folders between local device and remote device.

Q: Do you sync files via server or locally?
A: If both your desktop and your Android device are on the same local network (they are if they are connected to the same WiFi router) then all files are synced via your local network and they never go to any outside server. GoodSync Mediator server only helps in locating your device, it does not perform any actual file transfer.

One likely would have to install the Goodsync server to the OS3 My Cloud. See the section titled " Installation on old NAses, before 2014".


Kind people.
I would like to know, if an how I can transfer all my files from my my cloud to a hdd/ ssd. Is it possible to connect locally? If yes then how? I have a lot of important files on it and I like to transfer it to another hdd/ssd.
I would really appreciate some help.
Regards from Sweden

If you do not know how to connect the OS3 My Cloud to your local network, see the Support link at the top of the page and select your My Cloud device, then read the OS3 User Manual for your device which explains how to connect a My Cloud to a router and then access the My Cloud Dashboard to configure the My Cloud and it’s options. The following assumes one has a functioning OS3 My Cloud and it is properly connected to one’s local network. And if using Windows one has enabled SMB1.0 and configured the Windows Network Profile to Private.

How to Access the Dashboard on a My Cloud (single bay) Device

You have a couple of options for copying files to a external USB hard drive or internal computer hard drive. You can attach an external USB hard drive to the My Cloud’s USB port, then use the OS3 My Cloud Dashboard’s backup feature called either Safepoint or Backup to backup the My Cloud contents to that external USB hard drive. Or you can use Windows File Explorer or Mac Finder on your computer to copy files from a OS3 My Cloud to one’s local computer or to a USB hard drive attached to either the computer or My Cloud’s USB port.

To make things easier one can “map” My Cloud Shares for quicker access.
How to Map a My Cloud or NAS Device on Windows

How To Map a My Cloud or NAS Device on macOS

More assistance and help can be found both through the Knowledge Base link at the top of the page or through the following WD Knowledge Base Article.

My Cloud OS 3: Online User Guide and Solutions


Kind Sir.

My my cloud is no longer supported and I can’t reach it by internet. It is connected to a route, but since the support ended on April 15th I have no access to it. Could I simply connect the my cloud directly to my laptop and transfer all the content to another external hdd/ssd? I tried to lacate my my cloud using the dashboard, but without luck.

Kind regards


You will need to troubleshoot why your computer (or mobile) device cannot access your local networked My Cloud.

  • What color is the front LED on the My Cloud? Blue, red, yellow or some other color?
  • Is the My Cloud directly connect to your network router or network gateway? Do not connect it to a power line adapter, WiFi extender or mesh node, connect it directly to the main network router/gateway.
  • Is your computer directly connected to that same router or gateway using WiFi or Ethernet (wire)?
  • Can you access the router’s administration page to see if it indicates what IP address it is handing out to the My Cloud? If so make note of that IP address and input that IP address into a web browser to try and access the My Cloud Dashboard. One can also input that IP address into Windows File Explorer or Mac Finder to see it those programs can access the My Cloud.
  • Have you tried a 4 second reset or a 40 second reset on the My Cloud? Click here and follow the directions.
  • If using Windows, is SMB1.0 enabled and is the Windows Network Profile set to Private?
  • As a troubleshooting step, disable any third party security, anti-virus, firewall software on the computer to see if they are interfering with accessing the My Cloud.


Hi , is there a way to access the Nas drive remotey as well as locally? Is there such a app on ios? I have used Files to access if locally but would be great remotely too

One will have to use their own methods of remote access to OS3 My Cloud devices. One can use FTP which is not a secure method of remote access. To use FTP one would enable the option in the My Cloud Dashboard > Settings. And one would have to configure their router to port forward the FTP port to the My Cloud. Again, FTP should be treated as a last resort option since it is not a secure method of remote access. A better option using VPN. One can setup a VPN server on their local network and create a VPN tunnel to their local network (and My Cloud) from a remote location. There are various DIY guides for setting up your own local network VPN server.

Probably the best option, while not optimal due to cost, is to buy a newer NAS device (from Synology, QNAP or WD) that has remote access capacities and mobile apps. One could then copy the data from the OS3 My Cloud to the new NAS unit.


1 Like

Thanks Ben for taking time to write . I will look up to see VPN servers to see if there is a guide for this as I have no idea