OS3 My Cloud WD Remote Access No Longer Available After April 15, 2022

Per a WD announcement and an email they are apparently sending out. OS3 support is ending on April 15, 2022. This INCLUDES terminating remote access to one’s OS3 My Cloud device after April 15, 2022. Local access should still be available.

Support For My Cloud Changing
https://community.wd.com/t/support-for-my-cloud-changing/271763

Per an email:

Support for your My Cloud device is changing

Western Digital continuously evaluates and improves our hardware, software, and services as security standards evolve. As a result, we’ve determined that it’s necessary to end support for prior generations of My Cloud OS, including My Cloud OS 3. You should act now to protect your content.

On April 15, 2022, support for prior generations of My Cloud OS, including My Cloud OS 3, will end. Your device isn’t compatible with critical security updates that are only available for My Cloud OS 5-compatible devices. As a result, you’ll only be able to access it locally. After April 15, 2022, your device will no longer receive remote access, security updates, or technical support. To help protect your content, we recommend that you back up your device, disconnect it from the internet, and protect it with a strong, unique password. Check out our recent My Cloud updates to learn more.

Thank you for being a long-time Western Digital customer. We understand that your content is important to you, and we appreciate that you trust us to help you preserve it. To show our appreciation, we’re sending you a 20% discount coupon in January 2022 that you can use toward an eligible device. Keep your eye out for another email from us with information about that discount.

Sincerely,
My Cloud Team

(note emphasis mine)

Obvious workaround is to WD termination of remote access using their system is setup one’s own VPN connection to the remote network containing the My Cloud.

See the following link for much more information.

Support for your My Cloud and WD Cloud device is changing
https://www.westerndigital.com/mycloudupdates

Among the things that link indicates:

Q: Will my device stop working if I can’t upgrade to My Cloud OS 5? Will I lose access to my data?
A: Once the services have been shut down, you will still be able to access the device on a local network. However, access through the My Cloud OS 3 mobile app or web app will not be possible. Email notifications also won’t be delivered. Devices that have auto-update enabled will receive a final firmware update to disable remote access and outbound traffic to cloud services. Then, support will end and you’ll have to use the local network to access the device.

Q: I can’t upgrade to My Cloud OS 5, are there compatibility fixes planned for future desktop or mobile OS?
A: My Passport Wireless users will still be able to use the My Cloud OS 3 mobile app. Otherwise, the My Cloud OS 3 app will not be able to access any My Cloud or My Book Live devices.

I registered on forum only to give my feedback.

I never, ever buy any WD product if WD won’t revert this message. It’s unacceptable. I won’t recommend any WD product to company, which i work.
If my product stop work or any of it’s functions, i’ll return it to seller, seller will return it to you, and you can put it in your ass.

6 Likes

The end of OS/3 web support was inevitable. . .and many predicted that this day would come.

Obsolescence is a fact of life for ALL online services. At least here. . .they are providing an upgrade path (for most units) to OS/5. Now. . .if that path is viable, and acceptable to you. . .that’s a different question. If you don’t want to upgrade, and you need cloud access. . . .then you should start shopping.

This happened to me with both money management and photo editing software. . .the software company changed policies. . … and I promptly took my business elsewhere.

Me? I am making do without upgrading . . .and the OS/3 cloud apps have not really worked for me for a long time. No - - - not buying any WD products for awhile. . . .because I don’t like the new products.

1 Like

Breakout the popcorn indeed. Going to be a flood of posts and calls on and after April 15, 2022 by angry WD customers wondering what happened.

Gotta wonder what really happened behind the scenes to make such a drastic decision to shut down OS3 in such a fashion (abrupt six month warning). Was it security vulnerability related (like the My Book Live) or just another planned step (which some has speculated on) to push their EdgeRover content navigator?

Ahhh. . . EdgeRover. . . .that product sure was a raging success.

You know how I am betting on the “Why” question. :wink:

Honestly; even without the prospect of edgerover. . .does one seriously expect WD to maintain both OS/3 and OS/5 servers? I for one did not.

Maintain them indefinitely? No. Most who understand how business works knows there is generally a end of life date for computer products. Giving people six months warning? That is what some may have an issue with. In this case however because the remote access is tied (in part) to WD’s back end systems, this is going to come as a rude shock to those who don’t receive the notices or read the support forums. As most regulars here know, tying the remote access to WD back end was always a major issue and critical bottleneck. Any time it went down people lost remote access, sometimes for weeks.

But really, if one doesn’t want to update to a more expensive NAS they do have some options to continue their remote access (more or less). It just will be a bit more clunky and require some additional work by the end user to get that alternative remote access up and running. VPN is one viable secure option. But that isn’t for everyone though due to the knowledge and skill needed to properly set up a VPN server/client.

I don’t think it is a question of “forcing” users to upgrade.

Don’t attribute to malice what can adequately be attributed to incompetence.

  • Simply illogical to presume that both OS3 and OS5 servers can exist “forever”. If you gotta get rid of one. . .surely it won’t be the one you just invested alot of money into (not enough. . .but alot in their minds)

  • EdgeRover clearly didn’t go over well. And I think it is evident that much of the pain of OS/5 indexing process, and overall architecture, was related to a planned EdgeRover integration.

  • I doubt anyone is willing to spend the money to back out the integration of OS/5 and edgerover.

Note: The above are the speculations of random user who spends too much time on forums and not enough time outside. Speaking of which. . . .l am otta here.

I bought the WD MyCloud drive to back up data, and have seen the messages to update to OS5 on the webpage (as the app on the Mac stopped working as incompatible with the updated Apple systems). Not realising that my device would be incompatible I looked at the possibility of upgrading the system only to find that WD were advising backing up the data before starting this process - so I didn’t bother at that stage as I would need to buy the back up storage space to do this ( and it seemed as much to protect WD from loss of data due to potential slips in the upgrade) They have now come through to say my device is not compatible so I would have been wasting my time in any event. Nowhere are WD actually explaining why the firmware for OS5 cannot be retrofitted to the older models, which makes the whole exercise seem like a sales pitch to upgrade to WD. I had taken this route rather than using alternative Cloud servers partly on a cost basis. From my current perspective this now looks a better option as the supplier would have responsibility for security and given the virtual obselesence of the unit other than a disk storage why would I consider an ‘upgrade’ in hardware which will become unsupported in the future. Consideration should be given to the environmental impact of this policy, I would appreciate it if WD could explain actually why the firmware cannot be updated. We are expected to take it all on trust - and figure out how we can retain the data on a VPN and disconnect from the internet. There should be an idiots guide considering that we were idiots to buy the units in the first place,

There is a tacked/sticked post My Cloud OS 5 Firmware for My Cloud (with 2.xx.xxx firmware) which has several links including this one, My Cloud OS 5: Firmware Availability and Supported Devices which shows the first generation single bay My Cloud (v4.x firmware) is not capable of being updated to OS5. Several other older My Cloud models likewise cannot be updated to OS5 (My Cloud Mirror, My Cloud EX2, My Cloud EX4).

If one has a first generation single bay My Cloud, that unit has been end of support for a number of years now ( WD Product Software Support Status). The last v4.x firmware released for that device was over two years ago (9/4/2019). That unit could not be updated to the v2.x firmware when WD released the second generation single bay My Cloud that does run the v2.x firmware.

Fact is the hardware on the second generation single bay My Cloud is barely capable to run OS5 as evidenced by the many complaints (primarily about indexing issues) that are posted to the OS5 My Cloud subforum. And there are certain 3rd party apps and OS5 features that are not supported by the second generation single bay My Cloud running OS5 (My Cloud OS 5: 3rd Party Apps Matrix).

The first generation single bay My Cloud uses even less capable hardware than the second generation single bay My Cloud. (Differences Between My Cloud Products)

The discontinued OS3 support should not affect local network access to those My Cloud devices that cannot be updated to OS5. Those devices will continue to operate as before with the exception of the OS3 remote access feature which WD is discontinuing. It remains to be seen what happens with the OS3 mobile apps for iOS/Android and how crippled those apps will be. One can setup other secure ways to access their affected My Cloud device remotely once OS3 support ends. For example, one can setup and use a VPN tunnel to the network containing a remote My Cloud.

Note: The My Cloud Home is a completely different device than the My Cloud line and is not affected (apparently) by the end of OS3 support.

1 Like

Bennor is completely correct.

The old 1st gen MyCloud is . . . .functionally obsolete. Slow processor and not enough RAM.

If it works for what you do now . . .it will continue to work in all aspects - - -except the WD remote access servers and apps will end. . . … which was inevitable. If you really need that functionality. . .you are going to need to buy some hardware. When you look at this path. . .remember that you are starting over from scratch if you go with WD or if you go with a competitor (hint, hint)

Professional cloud services have their own warts. Besides the monthly fee.
Eventually, those services will “change”; or “go obsolete”, or get neglected. If you miss a bill for a month. . .don’t be surprised if your data doesn’t go poof. And you will then find out why the fine print covers 5-10 pages. Does your spouse or heirs have the account passwords?

There is a place for online backup. . .as part of a comprehensive strategy that includes backups at home.

2 Likes

Last Sunday I received an email that April 15, 2022 my WD MyCloud OS3 is no longer supported.
I think that’s too ridiculous for words.
You buy a product for certain purposes and after four years you can only use it as an external HDD.
A very cheap trick to generate sales.
I have multiple WD apparaten devices
From now on I will never buy a product from WD again and I will advise all my acquaintances not to buy anything from WD.

2 Likes

I see lots of posts proclaiming how this is not a real problem for the My Cloud devices because you can just use them as a normal drive. Well, my device is connected to the same router as my other office computers, and none of them can find it/see any files. Just how does one connected this turkey so it can be used as a local network drive? It shows under the Network folder, but clicking on that folder does nothing.

@peedee
Your issue has absolutely nothing to do with the topic of this particular thread. Start a new discussion thread where you can spell your your specific issue including the exact error message you are receiving when attempting to access a My Cloud Share and what specific troubleshooting steps you have tried. Also include your specific My Cloud model as well.

The My Cloud is not a “normal drive” it is a network attached storage device (NAS). When WD cuts off OS3 support next April the affected devices should still operate as a basic network attached storage device, just without the WD remote access feature and likely no future firmware updates.

1 Like

This change doesn’t really affect me. I can still get to my NAS on my local network.

I’m still using the “WD Photos” android app that’s been discontinued like three years now. It still works for Android 11. So if I can use that app three years past it’s end of life date then I can use this NAS years past their end of life date… or until the hard drive finally crashes on me. My 3TB My Cloud with firmware 4.05.00-342 has been going strong for over five years.

1 Like

Well, excuse me all to hell. WD’s discussion and support boards are obviously as useless and arrogant as Tech Support.

image001.jpg

If you want help with your specific issue, start a new thread in the appropriate subforum for your device, and ask for help. This thread deals with the ending of OS3 support. Your post states:

Well, my device is connected to the same router as my other office computers, and none of them can find it/see any files. Just how does one connected this turkey so it can be used as a local network drive? It shows under the Network folder, but clicking on that folder does nothing.

That is taking this thread discussion, which is about OS3 support ending, off topic. Sorry that you feel it’s useless and arrogant that a thread/discussion starter would want to try and keep the discussion on topic.

1 Like

Just bought my “My Cloud Ex2” in February of 2020 so its no like I’ve received long service from this device. What a ripoff

Are you sure it wasn’t an EX2 Ultra?

I have had an EX2 for a number of years. . .and I was under the impression that the EX2 was still for sale.

Was it an EX2 or the Ex2 Ultra? They are separate devices. Was it bought at retail, brand new or was it bought used? WD indicates the EX2 “last manufacturing date” was January 2016 and the last firmware released for the EX2 was 2.12.127 on 01/08/2019.