Not showing up win7 or server 2008 network shares randomly


#1

Hello,

I know there are some posts regarding this problem, but there was no solution for me.

My WD TV Live has the latest firmware since 2 days.

Since the beginning there was always a problem connecting to shares but it was solvable when resetting network settings.

Now with the latest firmware (and also the last one) I often have the problem, that the WD doesn’t show up network shares. DLNA servers are shown, but not the shares which are on the same machines.

2 Days ago everything worked with the latest fw (did a fw reset afterwards). Today I just turned on the TV (the wd wasn’t restarted, neither was the server) and suddenly there are no shares. Tried everything from rebooting, resetting, but no change. My other WD just works fine…until now because these problems are very randomly. It’s really not what I need, because I often want to show people videos or fotos from my servers and one day it works, the other day not.

DLNA Severs are still shown, but I just want to use shares.

Any solutions?


#2

In short, you need to make certain that whatever system is acting as the Master Browser for your workgroup is rock solid, and is fully operational before you power up your WD. My NAS acts as my master browser, it’s on 24x7, and never has an issue.


#3

The entire network is rock solid; just not the WDTV Live. I can say this too: My servers act as master browser and are on 24x7 and never have issues…

Networking works fine it’s just that the WD TV Live isn’t capable of browsing smb shares properly; even not listing any share (qnap, win7 or win server or whatever you want).

The Live Hub works.


#4

There’s a contradiction there; not sure if it was a typo:

 My servers act as master browser

…as in plural.   That can’t be.   There can only be ONE master browser, and it must ALWAYS be master browser.

If your systems are always on, and the master is moving from one server to another, that’s a problem.

Can you get a Wireshark capture from your Master Browser when the Live is having an issue?   I’d like to see it, perhaps I can find the issue.