Network shares not showing up

Up until this point, I had been able to access my network shares just fine. However, I can’t access either my desktop or laptop, running W7SP1x64 and W7SP1x32 respectively. When I go into network shares, all I see is my router (CISCO24599) which has always shown up for some reason. I always had to clear the login info a few times to connect successfully, but that was the only problem I’d had up to this point.

Attempted troubleshooting:

Restart all computers, WD, and router. Multiple times, in multiple orders.

Clear login info

Set static IP

Factory reset WD

Upgraded to beta firmware

Also, I can only see the attached HDD from my laptop, and not my desktop, which is a new issue.

FYI, it’s a Live Plus.

I’m guessing your router is a Cisco / Linksys somethingorother.

Go change the CISCO’S workgroup to something DIFFERENT than your PCs.

After you do that, reboot your PC(s) and your WD.

For some reason, The Cisco / Linksys boxes and the WDTVs do NOT get along when they’re in the same Microsoft Workgroup.  Who’s to blame?  I dunno;  I think it’s Cisco’s problem, but it doesn’t matter in the long run.

I have TWO Linksys E3000s, and I changed both of them to be on the workgroup called “ROUTERS.”  Everything else on my net is in the default group “WORKGROUP.”    That particular problem never occured again.

How do I change the workgroup of just the router? It’s an E2000, so the menu should be similar.

It’s under STORAGE / ADMINISTRATION.

Guess it’s not that similar.

Untitled.png

You sure you have an E2000?   According to Linksys, the E2000 doesn’t even do MS networking, so I am confused as to why it’d be in your workgroup at all…

Only the E2100L, E3000, and E4200 do it.  

Yep, definitely an E2000.

Untitled.png

Fixed it. Changed the workgroup the desktop is on from the default WORKGROUP to a custom name, and put the WD on the same WG. It now sees the desktop and reads it just fine.

Well, yeah, that’ll work to! 

Unfortuantely, I can’t see your pics until a moderator approves them.  

egloskerry wrote:

Fixed it. Changed the workgroup the desktop is on from the default WORKGROUP to a custom name, and put the WD on the same WG. It now sees the desktop and reads it just fine.

Now that your images are showing, I can see the confusion.  Your ROUTER is NOT showing up as SHARES, it’s showing up as NETWORK INFRASTRUCTURE.     Totally different thing.   :wink:

Either way, it sounds like it was definately a master browser issue between workgroups, the question would be now (if you care) what device was messing up, since it wasn’t your router.  :)

Hey man, had the same problem as you w/ the WDTV Live and the Linksys e2000.  I am about to try your fix now.  Just changed my workgroup for my desktop to WORKGROUP-NEW and now im going to do same on WDTV.  I guess the router will always default to WORKGROUP?   Any reason i wouldn’t want to do this? ie having my router on a different workgroup than my pc?

I would change the router instead of all the PCs, but it’s up to you…

Tony, what do you mean by that?

I ended up changing the workgroup on my pc and it worked. 

I have the e2000, so I don’t know how to change the routers workgroup.  Router doesnt have a setting to change the workgroup name.

Agggh!   Never mind, bbock…  I’m having a hard time paying attention.

The E2000 doesn’t do Microsoft networking, so I’m having a hard time grasping how it’s interfering with shares.   But you’re at least the seocnd person who’s been able to fix the issue by changing workgroup names, so I guess it doesn’t matter.

In short:  Never mind my post.  :)

Yes, I was able to see my shares by changing the workgroup of the wdtv and the desktop.  A new problem has occurred tho.  Since i got the e2000, I can no longer autologin.  I checked the registry to make sure i changed it properly in win 7 x64 ultimate.  I also turned off autologin, logged in, then reset login info and turned auto login back on (all in wdtv live seetings).  When I have autologin, it just hangs at “connecting…” and cannot access my shares.

If i log in as anonymous w/ a blank password, it seems to find them just fine.  I have not used it enough to see if its consistent, but the 3 times i tested it, I was able to get in when i manually signed in.

Any help would be appreciated. 

I run into this problem with my fathers setup of his wdlive plus, for whatever reason I couldn’t get the WDlive to autologin into the network share, it would normally hangup at connecting. Once in a while it would auto connect fine but about 90 % of the time it would sit at connecting. I just ended up telling him he would have to manually connect it no biggie but a little pain in the rear.  He had windows 7 home with linksys E2000

I’m having the same problem: My computer’s HDD won’t show up in network storage. It used to work fine a few months ago, but I hadn’t used it for a long time until today.

I changed the workgroup name for both my computer and WDTV Live Hub. My drive showed up for a few seconds and then I was prompted to enter a username and password. After entering the username and password (which at this time I am assuming is my Windows login and password), I received a message saying “known error”. Since then it isn’t showing my drive any more.

Strangely enough, I can still access the WDTV Live Hub hard drive from my computer.

I’m using Windows 7 x64 and Linksys WRT160N router. Any suggestions?

Geez…just got a refurbed Linksys e3000 today since my TP-Link router can’t hold an internet connect any more, and now I’m in the same boat as others - can’t access any of my WD devices via my Win7Pro64bit desktop. I don’t even recall having to set up workgroups when I connected the WD devicesbefore …they just worked.

Already I’m missing my TP-link…

update…oh WHEW! Renamed my router workgroup to “workgroupnew” & rebooted PC, and everything is now connected again.