Network Shares all dropped?

Setup my WD TV LIve box 1.5 years ago and has been working like a charm. I have a 4TB windows server 2008 box with the folders shared and the WD TV box on the same workgroup.

Usually in order to see content from the server I could goto video -> network shares -> scroll through all computers on network ( 6-8 different computers) until the server was found and select server -> movies -> content and play it.

I was watching a movie the other day, turned the box off, unplugged cat5 and used it on my xbox and then plugged it back in and the WD box doesnt seem to want to find any network shares or any network computers for that matter. The internet connectivity is still there because it can goto youtube, deezer, pandora, etc.

I have tried rebooting the WD box, resetting defaults, rebooting router, rebooting server. I tried shutting everything off, router back on then WD box on then server on and still it wouldn’t see drives.

I’m a little lost as to what happened? Running the latest firmware as of 12/11.

Your are not alone.  The same thing happened to me.  I don’t think its related to the newest firmware update because it worked fine after that…  Powered the WDTV off on Saturday, back on Sunday - No Network Shares.  The PCs I have that are running Win7 show up as Media Servers.  All other network functions work OK, just not Shares (of course thats where the movies are).  Suddenly the Enter button and the Right arrow button are just thumb exercise for the “Network shares” screen!  Just to test, I tried different firmwares back to 1.2.21. No difference.  Moved the WDTV to different points on the network - no help.  I’m at a loss.

I have same problem, after shutdown the computer where the LIVE box was connected to, no network shares at all are displayed?.. runnning latest firmware.

Hade the same problem yesterday but then the network share came back after power off and on the LIVE box, but today it’s impossilbe to see any shares whatever I do  (when using option media servers, all of  the nodes are displayed, but not for the network share)

If  I power of and on the LIVE box and connect to network share, I will for one second see the other box I have (Live hub) in the network share list, then it dissapear and start searching forever again.

An update…

My network shares in LIVE came back after 10-15 minutes after I turned my computer on again, may have to do something with this (see link) . I’ll test more tomorrow to see if the LIVE can see LIVE HUB (as network share) if they are the only hosts on the network.

http://community.wdc.com/t5/Networking/Troubleshooting-Windows-File-Sharing/m-p/92642#U92642

I guess we will just have to wait for some sort of fix. My problem is that it doesnt see 6-8 different machines on my network when it used to so I know its not a problem with just my server. Plus I’ve tried to reset everything already to no avail.

Note that per the Microsoft CIFS standard:   Shutting down the Master Browser can take up to an HOUR to detect, re-elect, and then distribute the change to all the clients.

Yeah, it **bleep**, but that’s how the standard was written.

FYI…  Although everything else was working OK, I rebooted my server (which was acting as the master browser).  Suddenly everything showed up and now works fine!  I may have to set up a middle-of-the-night automatic reboot every couple of days.

So I was doing some troubleshooting. I wanted to see which computer was the master browser so I started by running net view command via the command prompt. When I typed that in I got the message “system error 6118”. Basically this meant that none of my computers were acting like a master browser on the workgroup. I activated the “computer browser” service on my server and now that command shows the computers that are active on the server.

I’m going to check on my WD TV and see if the shares are up now and report back!