No network shares since update to 1.06.43

HI… never had any issues with my player, very happy actually.

WDTV Live 1.06.43 Windows 7, wired network and wireless, the WD is wired

After last update, my network shares are no longer visible on the WDTV.

Did a factory reset after firmare upgrade as usual, set the network to auto, no issues.  Cleared and redid login info. 

On my pc, i can always see a mapped drive to the wd.  I can move files to it no problem.  I can map a new drive, although the WD does not show up in the browse window, but if i know the path, it maps it.

In my network the WDTV box is not there.  Just my pc, and my wifes laptop when she turns it on.

On the WDTV, the media server part works, i can see files from my pc and wifes laptop.

The network share does not even give the chance to login to either, nothing.

The WD is in my router, shown connected whenever i look, except this morning it was not there.  I rebooted the router, it showed up, but it still was not shown in the Network.

The WD has a reserved IP.

I can always ping the WD.  and it responds.

SOMETIMES loging on and off my pc it shows up in the network all of a sudden.

SOMETIMES rebooting the router, turning off my pc and restarting, or powering the WD on/off makes it show.

Not always though, or maybe its a combination of one or two that makes it work, but i sholdnt have to.

I have not changed any setting on the pcs… worked flawlessly before.  Not a biggie, i usully move the files to the HD at the box when i want to watch, just more a "it isnt working right " bother.

1 - Any ideas?

2 - I couldnt find it quickly… where is the link to the last firmware before this update.  I was always up to date, used every frimware, so i must have been on the one just before this one.  And instructions on the rollback?  As i recall there is a edit to the file and the version # to fool it.

Rather fix it than rollback

Thanks. sorry if long, tried to give as much info as possible

Use a STATIC IP address.

Yes, that is different than a RESERVED IP, which still requires DHCP.

In my router settings, i have my pc set reserved as, WD as

So when you say use a static ip, i assume your referring to my PC?

strange, i actually had to reinstall Win& before xmas, and i usually do assign my pc a static.  seems i dint this time, so i will give that a shot

If you could just confirm thats what you meant.

Is there a link to previous firmwares?

Thanks for the response!

gave the pc a static ip anyways

nope no change.  I am not home to reboot the WD box… doing all this on remote connect.

and really would that matter?  PC always has the same ip as forced by the router anyways. Did that for my RD connection

if you meant static for the wd, i dont see how to do that… must be on the player ill look at home

drp58 wrote:

So when you say use a static ip, i assume your referring to my PC?

No, your WDTV.

Rollback firmware is here.

okdk give it a whirl when im home

do i still reserve ip on router?

set up static ip on pc,  and wd

is this a know issue with this firmware?

never had issues before

thanks again for input

Yes, leave it reserved in the router – just assign the reserved IP manually within the WDTV.

Lots of people reporting the issue on this firmware.

honey i’m home lol done… turned everything on/off reboot came up on the network list right away network shares on WD grabbed mine and the laptop but… thats happened before :slight_smile: ill see how it is in the morning before i check off on this FIRST firmware issue i’ve had i read lots of issues for people as i said im pleased with my WD Cheers

short lived, dropped away again fixes some and not others, or that was “the” solution? wait on another fix i suppose, if its common hopefully wd will release another… in a couple months or so

Uhm, did you do what I said?

Dont think i messed a step

Set my pc up with static ip, already had the reserve in the router

ip -

subnet -

default gateway -

going by memory i cant remote in as i forget my ip at home

already had a reserve in the router for wdtvlive

went to the wd box, network, manual, all the above was already in there, so i changed the to 109, saved, went back in manual and edited to 100 again.DNS here is

turned off the wd, my pc, and the router, all came up, and the shares were there… hour or so later gone could still ping WD, move files by mapped drive, media server ok, just the network shares gone

so what did i miss if anything?

strange indeed came home tonight, was in my network on the pc, but no network shares on WD even tried a different ip for the WD so…

Sorry, I’m out of ideas…

lol me too, as i said more a **bleep** its not working thing than a problem… still can move files easily

thanks Tony for the input and assistance!