Can't see Windows network shares after 1.4.10 update

I just installed the new firmware yesterday and now my WD TV Live can’t see file shares exposed by Windows machines on my network.  It does see network shares exposed from my wifi router and my linux box, but all of the Windows machines that used to show up no longer do.

My shares are configured to allow anonymous access and were working prior to this update.  Nothing changed on any of the Windows machines (two running Windows 7, one running Windows Home Server).  The Windows machines do show up in the “media server” section, as they are also exposing their media via DLNA.  However I’d prefer to use file shares where possible.

Have you tested the Reset button? I’va had similar errors, solved with a reset.

One thing that solved a “missing” network share in my case was going to the Workgroup setting and confirming what I had there (this causes a network restart) and voilá the network share re-appeared. (I had tried unplugging the device from power but even that didn’t work)

1 Like

@blackspawn, you just might be right. I remember going through all the possible settings and resets before quitting and leaving my unit rest for a few days out of frustration.

But now that I think of it, I just might have reconfirmed the workgroup at some point, but did not restart the WD Live.

Did you restart your player after resetting the workgroup?

I haven’t tried the reset, and haven’t had a chance to mess around with this lately.  Workgroup was correct and hadn’t changed through the firmware upgrade, but I also haven’t reset the device, only powered it off and on.


No I didn’t reset it afterwards, all I did was clicked on the workgroup setting and just clicked submit (I didn’t even change it - I left it exactly the way it was). WDTV then show a message saying “network restarting” and when it finished I went to check the network shares and all of them appeared again.

After that I had no problems with the network shares =) (which by the way, minus this little “glitch” are working MUCH better that with 1.02 and previous versions)


As I said, my workgroup was also working (and correct) previously and then suddenly I was unable to access the shares. Even though it was correct I still opened the edit screen and submitted again the value present (which cased the network restart) and that fixed it for me.


I just tried the workgroup modification, no dice.  I haven’t yet tried the reset, but I’ll play with that over the weekend.

The really weird think is that my linux machines and wifi router show up, but none of my Windows machines do (there should’ve been three – two Windows 7 machines and a Windows Home Server).  The girlfriend’s dual-boot windows 7 / linux machine only shows up when it’s booted into linux, not windows.

The Windows machines all see each other and the linux machines.  The linux machines see each other and the windows machines.  The WDTV sees my DLNA servers on the Windows machines just fine (WMP and PlayOn), so I’m using that for now but I’d rather use the file shares, for no real reason other than there’s no reason to put load on the DLNA servers if I don’t have to.

Well If I was in your situation the things I would try would be:

  • Rebooting the Windows machines (you probably tried that)
  • Reseting WDTV Live to factory defaults and reconfiguring the network
  • Paper clip reset WDTV Live (and reconfiguring the network)
  • Turning off all machines leaving only one windows one and see if it showed up (then re-adding each machine)
  • Changing the workgroup name in both the windows machine and WDTV Live

=) Yeah I know it’s buggy but *most* of the time it works eheh