Network Shares Work -> Update Firmware - > Network Shares Quit Working

I have been using a dedicated XP box as a central file system for quite some time now, and have never run into any problems. I have been prompted for the last few weeks to update the firmware on my WD TV Live Plus, but I never wanted to spend the time to do it. Today, I spent the time. However, after it successfully updated, it could not successfully find the network shares. I try to go to the right, and nothing happens. I go down and find local drives, press over to the right, and that works. I cannot, however, go over to the right when over Network Shares. Nothing happens. I don’t even get any message saying that no shares could be found (I dont know if I should or not, because it has never not worked for me).

Any help!? Its REALLY appreciated. Want to watch some movies now…

When you go into “Network Shares”, unless the share name shows up, nothing would happen if you “press right”.

If I shut down all my PCs, then there’s nothing there… if I turn this one on, then I have a single choice: “Jim”… if I also turn my server on, I get a second choice: “Server”… if I also turn on Mrs. RG’s PC, I get a third choice: “Sheri”.

It doesn’t matter that neither the server nor Mrs. RG’s PC are currently sharing anything with the WDTV… they are still on the network and show up on the list… it’s only if you select them that you get the “no media” message.

But if you’re not getting a share name to “press right” to, then something’s not right with the LAN… the WDTV and the PC aren’t seeing each other at all.  You won’t get a “no shares” message… there will just be no share name to “press right” to.

I agree that it may be something to do with the the LAN. However, I think it is at least partially caused by the WD because I used the LAN feature to watch a movie, then updated the firmware, and then it wouldn’t find it. Nothing was rebooted, nothing was shut off, and nothing on the network should have changed. I just went to settings, checked for an update, installed it, and went back to the network share screens. This is when I ran into my problem.

Does that help to clarify?

Hi mate,

after I updated to 1.06.15_V my network settings were reset to If I edit network settings to try to make them work again, they just don’t save, it’s always

That was my problem since upgrading, I can’t do anything to make my network shares work again. Going to try to downgrade.

Is this your case?

I haven’t checked as specifically as you have, but I have run some tests. I ran the connection test and I tried clearing all my saved network config settings.

How do you downgrade? I think this may be the best option as of now.


I downgraded my unit installing Firmware Ver. 1.04.31_V from here

Downgrading worked. I wasn’t sure if the link you specified was for the Live Plus version, so I got the download off the page you linked to.

Thank you very much Sergio. You are very helpful and I definitely appreciate the time you took to help me. I will definitely pay it forward!