Not seeing all my files and folders in MyCloud

I’m having a similar problem, and it is very frustrating. Here’s what I have found trying it on 3 computers in my house:

Computer 1:

  • Firefox works as expected.
    Computer 2:
  • Firefox displays 30 files. Cleared cache as tech support suggested but no fix.
  • Explorer displays all files in list view, 30 files in grid view.
    Computer 3:
  • Firefox works as expected.

The problem is, I use Firefox but have the same issue. Your solution is my problem. Anyone found the root cause yet?

1 Like

Unfortunately I have the same problem on chrome and firefox. But I found a little “trick” how to let the browser load all folders.
In general I think the programming of the website is the issue because it doesnt load all folders, it should load after scrolling to the bottom.

I found out if you zoom out to 80% in your browser (tested with chrome and firefox). the folders start to load (also when you scroll to the bottom). Tested it with over 150 folders. With 90% Zoom it doesnt work for me.

So try to zoom out to 80% and scroll down. This should load at least all files. Might be annoying to scroll out all the time.

And I believe this could be fixed easily! Seems like how the website was programmed. :face_with_raised_eyebrow:

Hope this helps!


Genius! That works.

WD should give you an award!
Thanks for sharing this hack!

You should put this at the top of the post. I had to read thru a million posts to get to this real answer.

Alper, so glad to find this workaround. THANK YOU ! This has been driving me crazy !!:grin:

I had same problem so I read all of this thread with keen interest. (too bad some posters forget that they are flipping off at “volunteer” help)
Anyway, all I want to add is that the very last posts that refer to changing zoom worked for me too but in a funny way… I was at 90%, so tried 75, 50 40 to no avail… BUT when I went to 100% voila…they all appeared (in IE). When I tried firefox, they did all show up but I was persuing the IE fix as that is my preferred browser.
Oh well, other than that I have had no issues with mybook or mycloud. It took some learning only because I would get upset that I file would not upload, only to later learn that it was because the same file was already there (my bad)

My friend you are genius indeed… Thanks for sharing

Kudos to you~ that works like a charm.

Shame on those WD Web Programmers - their page load scripts stop firing pre-maturely when it reaches page bottom up to the screen resolution. By changing the zoom, it re-arranges the browser layout, changes the scroll length, hence triggers another round of firing of their loading script.

WD, please have this fixed ASAP! This is lousy coding, a real shame!

Hi There!

If you still having problem with this, here’s the solution. It can work in any browser.

Just zoom out by scrolling your mouse while pressing Ctrl.

Now, you can see all of your files. hehe

I hope it this would help.

YOU ARE A SAVIOUR. I cannot put in words how much your solution helped me get through the stress!

:exploding_head: O…M…G…!!! You are a GOD SEND, Alper!!! :star_struck:

:tada: THANK YOU, THANK YOU, THANK YOU!!! :tada:

This issue has PLAGUED me for sooooo incredibly long. :woozy_face: I attempted to map the drive on my Windows 10 laptop as a work around (which resulted in sooooo much frustration and MANY lost hours) before settling on making multiple folders (0-G, H-N, etc.) and moving my files to the appropriate ones. TALK ABOUT TEDIOUS! :confounded: :weary: :dizzy_face:

Then I decided to make one last ditch effort at a solution search and I found your post. I figured, “What the heck?” and tried it out. On my Chrome (Version 80.0.3987.149) I had to decrease the zoom to 67% BUT IT WORKED! :exploding_head: I couldn’t believe it so I tested it on other folders that I knew I had the same issue and again IT WORKED! :star_struck:

Alper, you saved my sanity! :tada: With all this COVID-19 anxiety going on right now, I GREATLY appreciate you posting your discovery and saving me the unnecessary added stress as well as the loss of time. :star_struck:

:unamused: Western Digital, you should REALLY get together with Google to fix this blasted issue. Just saying…

agree with other posters, this was genius. Don’t know how you worked it out, but I had tried all the other suggested solutions, and this was a godsend, thanks again.


I found the entire explanation :

Only Windows 10 + Chrome/Firefox/Opera can’t see more than 30 items by pages.
The Alper’s solution helped me to understand where is the real problem : it’s due to Microsoft Windows display Zoom

If, like me, you selected 125% instead of 100%, you should get the issue ! So you should use the 80% zoom level in Chrome/Firefox/Opera.

So to complete the Alper’s solution :
Either you set to 80% the navigator zoom level, or you set the 100% zoom level in the Microsoft Windows settings/Display/Scale and layout

Anyway, since it is a main feature of myCloud, I beleive that WD should take care about this issue and try to be compatible with the Microsoft zoom feature !
How should you do if you have to share more than 30 files with anyone who does not know this fix ? You will have to explain every time you share a folder ? From my point of view, it’s not beautiful work, it’s hack…

Alper you are a genius! I had tried keeping my finger on the scroll I had tried all sorts of ■■■■■ games to get my files to load, I came to the WD community expecting to find lots of dross and cursing and frayed tempers - and I did - and then I found your post. Congratulations! You definitely get my vote. :innocent: :smiling_face_with_three_hearts: :+1: :beers:

i have same problem.
my cloud just show 30 folders.
but, i found simple way to fix it.
i just “zoom out” the browser, and i did it.
all folders is show.
you can try it bro… :star_struck: