Share Link maxed out to 30 files. How do I view them all?

I’m currently running v04.04.05-101 on My Cloud and I can see all files via network folders on Windows 10. However, when I send a link to share my files remotely (from any web browser) I can only see 30 files in a folder that contains 45.

How can I view all files via the web link?

Are all of those files located within the same Share and the same folder? Are those files listed within the WD My Cloud desktop app or the WD My Cloud web portal?

Realize old issue, but same issue exists. Looks like firmware issue. WD should check.

Found a post in the WD Community that referenced the issue and actually solved it for me. However, I still think it’s a firmware issue and I don’t particularly like the fix. Something else to have to remember. The fix is to set the browser to zoom level 100 percent. Looks like anything other than 100 %, as i’m a little blind, I default all my browsers to 125%, but nonethless, if I set the zoom level to 100%, then I can scroll through all the files. If I set to anything else, It stops at 30 files.

It is probably not a firmware issue rather a problem with the web portal coding since it appears to only happen when one is using a web browser. See the following recent post where one user comments on the issue and what works for them. It appears one has to use 100% or the problem appears on certain web browsers. Try different web browser and see if the issue persists.

So when I tried this at work earlier, I thought it was the 100% thing. And could be for the Chrome browser I use at work. I came home and it did not work on my normal laptop. I broke down and launched IE from my Windows 10 Pro laptop and it worked immediately. All 278 files appeared. Trying to use Chrome and Firefox was sketchy at best. If I zoomed in and out a few more files would appear with no rhyme or reason it seemed. But all the files still were not there. Using IE seems to work. Sad. If it’s not a firmware issue, then how else is the Mycloud controlled to offer up web pages and content? I suspect if they correct the issue in the firmware it would work across all browsers. Hopefully someday they figure out how to use Edge as well.

Seems to work completely with Internet Explorer 11. At work, I use Chrome and it also works. Very frustrating simple web page can’t display properly all files on different browsers. Seems the personal cloud interface and functionality was an afterthought of sorts.

Thankfully Windows 10 still has IE available for now. Seems to work ok. Just have to remember to tell anyone I send a link to possibly use IE to display all files.