No Network Connection

My Cloud device will not connect to home network. Unit has been rebooted, Patch cable changed, Switch port changed and connected directly to Fios router still unable to see on network. Ethernet lights solid green and flashing green second light (doesn’t flash as fast as I think it should). Solid blue light on front of device once fully up, when I disconnect and reconnect ethernet cable the light flashes white then solid blue.
Any suggestions? I have not pressed the reset button because I didn’t want to loose what data I have on the unit.

Just to let you know My Cloud Home WD server is down. I could not connect to mine over the net but can connect locally. Are you using the WD My Cloud app or mapping directly to the My Cloud via TCP/IP? What OS are you using?

Does your router have the switch ports or are you connecting via a switch to the router? If you have a separate switch ( I have this config on my network) try connecting directly to the router if possible. Yes, you switched the port, I get it, just asking.

Next possibility does your router have a client area where you can see what is attached. Do you see the My Cloud device?

1 Like

I had that issue recently when I added a switch and moved MYCLOUD back to main router. IP addresses changed and I kept getting flashing lights. I did the quick 4 sec reset and immediately logged back in and re set passwords. All data intact. Hope that helps.

Found issue, I had a static IP address (10.20.1.xx) in the device and when I reset my Nodes they picked up a new network ip (10.26.1.xx). Made corrections to network ip network connection solved…

Thanks to all that took time to reply…

We are suddenly unable to access our WDmycloud mirror. On the dashboard I have been into… Settings>>cloud access>>connection status “Failed”. Also getting a failed message on our PC when at our office some miles away. I have no IT skills whatsoever, but have tried rebooting router and WD unit. But the same message comes up. Can anyone help with a simple step by step guide for an IT dummy please? I don’t understand about IP addresses etc., although I have found the router settings.


We are having the same issues. Cannot access remotely, but can get on via WiFi on site. Trying to figure this out now as well.

We are also having the same connectivity issues. We can access while on our same Wi-Fi network, but not once we are off the wi-fi.

1 Like

Same here as Janice6872. At my office network it is doing well but I try to access it from home and I get this:

Same issue. Have an EX2 that installed without issue a year ago or so. Since them there are periods where we can access via the local network, but can’t get there via internet. The suggestions displayed by WD is to make sure the device is on the network and that the firmware is up to date, both are not issues with our device.

Sent a note to WD per instructions when the issue occurs. No response. I’m about to throw out this expensive piece of junk.

By chance have has anyone having this problem verified that their subnet mask and gateway settings have not changed? Just a thought.

Same story, cannot access from Internet, access is fine when inside the network.
Told by WD Support that they are working on it. It’s been a week and still nothing.
Subnet and gateway settings have not changed.

Call them the support line. They already have me on line. They used the error messages from the phone app.

Not sure exactly how to determine things like static IP, subnet and gateway settings. Logged on to router admin. IP is (the router is 1.1). I assume this means the IP is dynamic. This is a simple home network, so can’t imagine ever making changes after the initial install.