No dashboard, repetitive prompt to set up the device

Hi all,
I am very new to all this. I just got the mirror second generation device and I was able to connect only by typing the device IP address on the browser. After I set up the account for me, I received the confirmation email and everything looked ok. I even logged in with my android phone and uploaded some files. The problem is whenever I try to connect to the dashboard (either by http://wdmycloudmirror.local/ or the IP address of the device) I get prompted to the set up page again to select language etc. I have a macbook pro, and through Finder I can access/browse/read the files of the device. So my problem is the dashboard (i think). FYI, i am on a macOS 10.12.3 Sierra. I already tried reseting (4sec) with no success.

thanks for your help!

edit: I can log in to the device from finder using the admin account that I setup. So i know the setup worked

suggestions? anyone?

ok I continue, i realized that although I can connect from Finder to mycloud as admin (the password I setup), when I try to map the disk, it doesnt accept the same username/password!! Also, when type the mycould local IP to the browser, I actually get the dashboard to enter username and password. Again, If i type admin and no pass I get prompt to set up the device as if I just turned it on. If I use the account i had set up, then i cant connect…
kind of desperate here…