My Cloud Mirror running fine, but dashboard does not come up in browser

Hi - We have a WD MyCloud mirror (Gen2). It’s attached to our modem/router, and accessible on our network, but the dashboard is no longer accessible in a web browser. (It just says the site cant be reached)
I’ve tried manually powering off the the MyCloud, restarting the computer, etc. , to no avail.

Does anyone know what I can do to troubleshoot / fix this issue?

Thank you


If your MyCloud is getting its IP address via DHCP, it’s possible that the IP address it currently has is different than the one it had when you last connected via a browser. Check the devices connected to your router to find the IP address of your MyCloud and then try browsing to that address.

For example, if the IP address is, browse to

Thanks ! That was very helpful! it worked.

I was using the http:// 'wdmycloudmirror.local ’ URL which used to work. And I was also trying the IP address as the URL, it seems like that has changed, so looking at the router devices helped and I found it, and it works!
Not sure why the first URL fails, but this is working so I’m happy. Thanks for the help!!


Did you change the name of the device in the dashboard?

It’s only http://wdmycloudmirror.local for devices using the default name(wdmycloudmirror), otherwise it will be http://whatevernameyougaveit.local (of course inserting its new name as appropriate).

Thanks Darren - No I haven’t changed the name, I just double checked the dashboard and the device name is still ‘WDMyCloudMirror’. Strange that URL stopped working.


In that case I’d double-check that the machine you’re using has Apple Bonjour installed and running correctly on it. If I remember well that is required to access the .local type of domain links.