No dashboard after IP change (and 40 second reset)

My Cloud 6TB. Running v4 firmware. It was version updated last spring or summer (can’t recall). 1.2TB of files.

After a router upgrade, it was kind of giving me fits changing the IP address (so I changed from static to DHCP). I know the current IP. I can access files from Windows Explorer (even now).

Now the dashboard won’t come up (using the current IP or the FQDN).

During various attempts, I reset it at one point using the power-off, reset press-and-hold, power-on, release reset button after 40 seconds.

At that point I can get to the Twonky server (all media was previously disabled, as I was only using this for a basic NAS) on port 9000. (Sadly, I never enabled SSH… everything’s worked great for two plus years, so I never bothered with details like that.)

Twonky Status shows the database as rebuilding (its at the 11 hours plus mark). Actually, all the Twonky menu pages seem to work fine.

But the Dashboard page… don’t work. (I tried using port 8000, but the result was the same error message.)

The WDMyCloud applet, when I press on info, shows firmware version 0.0.-1.

Does anyone know what that means? Something… bad?

And is there anyway to auto-install or auto-reinstall firmware from, maybe, a USB drive? Or something?

Or some unknown-to-me port that might get me to the Dashboard? (This time I’m definitely enabling SSH, sigh.)

Do I just need to wait until Twonky finishes whatever it’s doing (at this rate, it will be weeks: I have over 70GB of photos alone on there).

…I can backup the files to another NAS… which will take days, right? Would reformatting the drive at that point work?

I really like the thing. (Although I have clients with the v2 firmware of this, and all of that version firmware are faster than the v4 firmware devices. Dunno why. Just reporting my observations over ½ dozen plus MyClouds.) This is my screwup, not WD’s.

Thanks in advance.

What happens if you remove the My Cloud from the router and connect it directly to a computer’s Ethernet port? What is the make/model of the router?

In certain cases the router can cause a conflict with the My Cloud. The workaround is to use a network switch between the My Cloud and the network router.

What is the “WDMycloud applet”? Is it one of the WD programs (WD Sync, WD Desktop, Smartware) or is it one of the “tray” icon programs that gets installed by WD Sync or by WD Quick View or WD Access?

Can you access the My Cloud Dashboard using the My Cloud’s IP address? The port isn’t “8000”, the My Cloud Dashboard typically uses the default web server port of “80”.

It’s a fairly recent (well “I think”) MikroTik hAP RB962UiGS (moving to MikroTik for various, client-related - I consult - reasons). I will read that article (the WDMyCloud6TB is directly connected to a Netgear switch if that matters… thought I read that it might somewhere… lol: yeah, I did read that and you included the info … been doing a lot of reading lol).

I didn’t even think about connecting the MyCloud directly to an Ethernet port. I will try it and follow up.

As you guessed. “applet” refers WD My Cloud Desktop. But that is a tray “applet” (it also lists WD Sync and WD Access): so is there a My Cloud Desktop full blown application that I can download and use (I’ve always just used the browser Dashboard).

I tried port 192.168.88.xxx:80 after seeing your suggestion aaand… same thing. No Dashboard page. The Twonky page on port 9000 Status option still shows the “rescan folders” plugging away :wink:.

…it’s been that weird firmware version 0.0-1 that has me more worried than anything else. (Well, that and the prospect of weeks for it to finish “whatever its doing now” lol.)

Note that while the WD My Cloud Desktop program may work with the first generation v4.x single bay My Cloud units the software has been end of life for a number of years now.

What color is the front LED?

It’s solid muted blue.

So the odd firmware version 0.0.-1 that is showing up in Properties may be due to some EOL weirdness in the tray icon software being obsolete? -That’s a relief. (I’ve been wondering if it tried to upgrade after I finally got the IP changed, and I corrupted something-what-I-don’t-know during various ill-advised restarts.)

…I haven’t tried plugging directly in yet. Will try shortly.

Update.

I didn’t get a response from plugging in directly using Ethernet; presumably I need a crossover cable (I know I have one… someplace… but it’s been years lol).

I plugged in the USB cable to a desktop… and something interesting (probably coincidental, but “who knows”) happened. The MyCloud is now fully showing up in my [home] network Network list. Under the Storage and Media sections, and in the Computers list.

So I’m cautiously optimistic at this point, that the 40-second reset back to factory settings didn’t completely hose the thing (nor the possibility that there was a firmware auto-update that I rudely shut-down while I couldn’t see the Dashboard screwed something up).

And that maybe it’s just taking an inordinately amount of time to “self-heal” (or whatever it does).

So for now, I’ll give it another couple of days and see how stuff develops.

Thanks for all your help Bennor. I’ll follow up with results when I have some lol.

Generally the USB port on the My Cloud is for connecting external USB hard drives so one can expand the storage space and have a backup (Safepoint / Backup) location. It does not typically work to connect to a computer’s USB port so it can behave/work like an external USB hard drive would.

More likely the My Cloud finished it’s indexing post reset and hopefully is operating normally. Sometimes, depending on how much data is stored on the My Cloud it may take a very long time for the drive to finish indexing and performing other reset tasks.