No backup targets found after installing WD backup

I am a new user of WD Ultra. After I installed the apps by checking the recommended installation, I only found the shortcut icons of utilities and security. No WD backup showed on the desktop or the Start menu. After installing the WD backup specifically, a pane asked me to select your WD storage device… then it showed “No backup targets found” even I click the Rescan button twice. The WD Ultra is connected to my PC. Any help will be appreciated. Thanks.

Hello, what operating system you have installed on your computer? Have you tried installing it on a different computer?

I’m using Windows Vista, and I haven’t tried a different computer. I tried to uninstall all WD apps and reinstall them again. Same result.

Hello, you can try to use the WD Smartware to backup your computer, as it seems that the WD Backup is not being installed on your computer.

I have wasted over an hour trying to get this rubbish to back up.
I have also installed WD Smartware but that seems to only want to back up to dropbox.
the computer sees the drive and downloaded programs off the drive.

I am using windows 10.

does MY Passport’s software not work?
should I just take it back to Tesco?