New wd tv and wifi won't work?

I just bought a new WD TV that has built in Wifi.  When I turned it on it found wifi networks. 

It did a bunch of firmware upgrades and then all of a sudden I have no wifi options anymore. If I go into network settings it says it can’t obtain a ip address. I have done a bunch of resets on the unit. But it never asks about wifi ever again. I have also tried rebooting the router and modem. Plus I have tried turning on the wifi security and that didn’t work. Hard wired it works fine… What am I doing wrong ??? Chris

Did you do factory resets via the internal menu. Did you go into the network setup and see what wifi networks are found.

Under networking there is no wifi option.

When I go to it it asks if I want to do do it automatic or manual.  Automatic doesn’t connect to anything.  Is there somewhere else I can find the wifi info?

i have done resets from the internal menu and I have done a reset but putthey the pin in the bottom of the unit.

Get the same results.  Any help would be great.


I think your post is in the wrong forum. This forum is for the 2009 model WDTV Live HD and 2010 model WDTV Live Plus.

The forum for the 2011 WDTV Live Streaming Media Player is here:

But anyway, you can try rolling back the firmware to a prior version.

Ok this is really bugging me.

I have gone back to firmware 1.04.12 and I still have no wifi option.

You would think under network setup there would be an option to select wifi and pick the network.

What am I doing wrong?

Probably nothing you did wrong.   The hardware may be dead.

If the internals don’t see the presence of the internal WiFi adapter, that option won’t be shown.

So what do I do?

Uhm, replace it?

Before I box this up and drive to return it is there any other things I haven’t tried?

When I go into Network in the setup should it say WIFI?