Brand New WD Live TV won't connected with wired connection

So I just bought one of these little boxes and right out of the gate, I can’t make it connect to my network/internet connection.

I am using the wired option and asking it to connected “automatically”

Every time I try to have it connect it says “Unable to obtain an IP address.  The WD TV has limited or no network connectivity”

My router is a Linksys E4200 and it’s plugged into port #2 if that matters.

I have tried different ethernet cords, different ports on the router, resetting the router, resetting my cable modem and nothing changes.

I even tried plugging in a laptop into the same ehternet cord just to make sure that cord was in fact working… it is.

This thing seems like a door stop to me right now.  Anyone have a suggestion?

Have you tried a different cable and set the IP manually?

Yes, I have tried several ethernet cords and I have tested them all to ensure they work on other devices.

I have not tried setting an ip manually for this device Until now.  Same result.  Still doesn’t connect.

Check your router’s DHCP table. Is it assigning an address to the WD when the WD is set to automatic?

Does not appear in the DHCP table. It also does not show up as a network device on any of my Windows PCs that are on that same network.

 Do you have a laptop you can connect and verify it gets an IP? If your laptop gets an IP then you’ve ruled out the router, the cable and the ports. Are you able to control the ports speed on the router’s ports? If so, you can try hard coding a link speed instead of auto negotiate.  Assuming all of this is fine or you can’t change it…

This leaves the WDTV box as the issue. So, you can try upgrading to the latest firmware. Before you do that, reset your device to facgtory defaults. If you are already at the latest firmware, try rolling back one version of firmware. again, reset device to factory defaults before rolling back. If you roll back, and it still fails, try upgrading back to the latest firmware after resetting to default settings. If after all that you still can’t connect, you can try going to another location and test it, frriends house, Best Buy, etc… or return it for another one.