WD Live TV cannot connect to WI-FI network! Please Help!

I had this product for over two years and it was working fine. As of yesterday it simply lost ability to connect to WIFI network. I tried twenty times and no avail. Reseted the unit to factory state with firmware 2.01.86 but still the same. When I go to Setup/Network Setup/ I do not get an option to select wired or wireless network, only Automatic and Manual. If I tried any of them I get a prompt “Unable to obtain IP address”.  I am desperate and losing it - I am affraid I am going to toss it over my window.


If a full factory restore doesn’t fix it, it sounds like the internal WiFi interface has failed.


Is there a way that I can confirm that before I discard the unit?

It seems my unit has a mind of its own. Now I Can see option to connect on WI-FI. Last night I was able to connected sucessfuly and it was working as a charm for a couple of hours. Than video froze and when I restarted I could not connect again. When I turned this morning it was OK again but after an hour SAME S**T!


Now I cannot connect to my WI-Fi. Well it is “connecting” but I cannot access anything on my LAN and when I check network connection it shows IP is valid but cross mark on both DNS and Internet connection.


I really dont understand how this thing operate.And why it works and than stops working.


Please help!