New Release - My Cloud Firmware Versions 2.30.193 (05/17/2018)

WD is happy to announce the release of the My Cloud Firmware Update 2.30.193 for

  • My Cloud
  • My Cloud Mirror Gen2
  • My Cloud EX2 Ultra
  • My Cloud EX2100/EX4100
  • My Cloud DL2100/DL4100
  • My Cloud PR2100/PR4100

What’s new!

Updates to enable compliance with EU privacy regulations.


We all know that will NEVER happen!!!



mp3 and videos aren’t be able to play as before. what happened?

Can you provide more details please?

  • How are you attempting to play movies and mp3?

usually i just open my iSO app on iPhone and select the file, if that’s mp3 mpa, it will play music under mycloud, then if that’s mp4 mov mkv then it will load VLC to play the video, and they were still ok before i update the app from app-store. just right after the update, audios just unable to play media file, also the videos aren’t able to play anymore.

@Larry.F I just deleted and downloaded My Cloud App for iOS on my iPhone 8 and movie and video play as expected. You may want to:

  • reboot your PR unit
  • close and open the app

I deleted the app and reinstalled it on my phone but still not able to play, so I think I will reboot the unit when I get home.

Will update the result, thank you SBrown

Well don’t shoot the messenger (:pie: @SBrown). I figured a compliance change would just involve reworded legal statements and @dswv42’s breakdown seems to confirm that.

that worked like before after doing what you’ve told. thank you very much sbrown

Do you think one of those .PHP files solves this vulnerability?
Nessus plugin name:
Portable SDK for UPnP Devices (libupnp) < 1.6.18 Multiple Stack-based Buffer Overflows RCE

Vuln Solution:
Upgrade to libupnp version 1.6.18 or later. If libupnp is used as a third party by a different application, contact the vendor of that application

Not likely (there are known issues with 1.6.21 as well, UPnP has always been a security headache), but if you are curious to test your own box, there is a Metasploit module that could be tested against previous firmware. D-Link had this issue, and we learned earlier this year about the shared code between D-Link DNS-320L and the MyCloud family :zipper_mouth_face:.

Edit: Current firmware seems to be using libupnp built with version 1.6.6 (thanks to @Tfl for teaching me the joys of ldd and similar tools :slight_smile:).

My WD Cloud EX2 Ultra does not sleep any more after this update. I have not made any changes in the settings. What can I do to restore automatic sleeping?
Problem solved using:

My PR2100 also does not sleep after update. Drives continually “ca-chunk” quietly but is annoying as it never stops. Have contacted WD support. Device tests show no problems. Access to the device is normal. They even had me do the system only reset (40 second reset). Any reboot of the PR2100 shows a log entry for Media Scan Interrupted".

Problem solved! I took a Photoshop class and for some reason decided to try something in Lightroom. Lightroom created over 100,000 files from my photo library (1 per photo file). I deleted the Lightroom folder from my private share and the public share. So 200,000 fewer media files on my PR2100. Now my PR2100 is resting comfortably.

hi my, my cloud tried updating to this and i guess failed. as i have a solid green light is my my cloud now bricked?