My Cloud Firmware 04.05.00-327 (05/08/2018) Discussion

WD has announced an updated firmware for the first gen single bay My Cloud units.

New Release - My Cloud Firmware Versions 04.05.00-327 (05/08/2018)

Feel free to discuss what is good/bad about this latest firmware. The release notes what’s new indicates only the following: “Updates to enable compliance with EU privacy regulations”.

Firmware Release 04.05.00-327 (05/08/2017) | Release Notes
Direct link to firmware:

Direct Link will be fixed shortly

After applying this update my videos folder is not being picked up by DNLA. I can access it via Windows Explorer, but any media device on my network, that can normally access my videos are not seeing them.

UPDATE: After resetting the device I can no longer see it on the network :frowning:

Everything was working fine until I applied this update…

Couple of things to check. First ensure media serving is enabled on the Share containing the media files. When resetting the My Cloud it is possible, if one hasn’t configured the router to assign an IP address to the My Cloud, for the My Cloud to obtained a new IP address. Check the router’s administration page to see what IP address is being handed out to the My Cloud.

Before it completely stopped working (the main issue at present), I checked and media server was enabled.

Given the IP is dynamic, (DHCP), I tried browsing using the my cloud address, no go. I assume the light needs to be blue first?

It’s not appearing in my device list on the router, and not browseable.

Yes the front LED should be blue. If it is not what color is it? It may take a while for a My Could to rescan the media if one has a lot of media stored on the My Cloud.

One may also want to check the Twonky administration page (example: http://mycloud:9000) to see if the missing media folder is being excluded/listed.

The light is white, and I can’t access the device at all from the browser.

Have you changed anything else on the local network? Like using a new router or broadband provider?

Per the v4.x My Cloud User Manual a solid white front LED indicates one of the following:

Device has begun loading the Operating System (OS).
Firmware update in progress.

A flashing white front LED indicates the following:

Displays when you first apply power to the unit.
Reset pressed.

Nothing on the network has changed. The only change was applying the last firmware upgrade.

Note I have tried resetting the device. The 4 sec reset did nothing. The 45 sec reset also appeared to do nothing, but would have wiped its existing network configuration if it did what it was supposed to.

Just to make sure your doing a reset correctly…

I’ve done update no issues so far

As your network may of defaulted following the reset, change the mycloud IP address to static and reserve thus jn your router so it cannot be issued to another device and cause a conflict

For DNS Settings, set DNS1 as and DNS2 to and save, this works following an issue months ago in a similar scenario

@Lasher Blinking White LED means the unit is running a filesystem check. Any attempt to reboot will just start the process from the beginning. Let it run to completion and until the LED is solid Blue

Tough to set static IP if you can’t access the device…

I’ve had it running 24 hours since the last reset. The light is solid white.

I had already tried both the 4 sec and 45 sec reset options. The light is still white and I can no longer acces the device.

(Note, in both cases - the 4/45sec resets, nothing happens. The device does not automatically reset)

I’d love some direction on how to access the device directly other than the network (if possible). I’m also an IT developer. Happy to telnet or somehow remote to the device if possible.

It’s not a “45” second reset its a 40 second reset, using the reset button on the back of the unit.

One option is to remove the hard drive from the My Cloud enclosure and attach it to a PC running Linux to see if the data and file structures are still there. One could even try one of the unbricking methods for the v4.x firmware My Cloud units as a last resort.

According to the link you quoted it’s “hold the reset button for at least 40 seconds”, so I don’t know why you are correcting me from 45sec to 40 secs when 45secs is as good or better then EXACTLY doing 40 secs. Please try and be helpful without the snark. Holding button in for 45 secs is better advice than “It’s not a 45 sec reset”.

Given I and 99.9% of the population don’t have access to a PC running Linux, could you please advise some other check, or possible instructions on how to rollback the last firmwire update? Although this is not doable while I can’t access it…

Right now as I type this, the unit is powered on, connected to the network/router with a white solid light.

It is not snark. WD calls it a "“40 second” reset even if they tell the user to hold down the reset for at least 40 seconds.

One can download and run Linux without installing it. Ubuntu us one popular distro one can run from a USB flash drive or from CD/DVD.

If the firmware update was corrupted and one cannot gain access to the My Cloud using SSH or the Dashboard, one is probably limited in what they can do. One could always contact WD Support directly and send the unit back for repair. Otherwise removing the drive and accessing it using Linux is one option. Not sure it telnet or usb booting works on these first gen units.

This all assumes there isn’t some other problem with the local network or with the My Cloud enclosure preventing the My Cloud from obtaining an IP address.

It is also possible one may just have to leave the My Cloud sit and possibly continue it’s internal scan which could take several hours.

Ok - update…I rebooted it and after about 10 mins the light turned blue (at last)!. At that point, I was able to browse to the IP address. The configuration had reset (as expected). The media server was rescanning. I was able to reconfigure it (renamed the device, re-enable the media shariing on some of the shares, and got my mapped drives back up in Windows) and Twonky was also rescanning. At this point, WD Access software running in my system tray started throwing up notifications of all the previoes restarts over the past 36 hours. So all looking hopeful. However…

I walked away and have come back an hour later. The light is back to white and I can no longer ping it. It basically has disconnected itself from the network.

Now it’s possible I am having networking issues and there’s nothing wrong with the unit, however, everything else on my network is working fine. I have even swapped ports, cables and plugged the unit directly into the available network sockets on the modem.

If you can SSH into the unit the next time the led is blue. Leave it connected until
the light turns white. If the network is OK then you should still be able to run commands
thru ssh to see what is running.